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Upgrading or Licensing QlikView with an expired Maintenance Contract

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Sonja_Bauernfeind
Digital Support
Digital Support

Upgrading or Licensing QlikView with an expired Maintenance Contract

Last Update:

Nov 2, 2022 6:14:01 AM

Updated By:

Sonja_Bauernfeind

Created date:

Dec 14, 2015 11:32:44 AM

Upgrading QlikView fails with the Warning: 

You need a valid maintenance contract to be allowed to install and use this Software

Warnings You need to have a valid maintenance.png

 

Proceeding with upgrades without an updated maintenance contract will lead to the QlikView Server license being invalidated. The server will enter Off Duty state. 

Attempting to license a QlikView server with an outdated license will lead to 

Server failed to set license: QVS@qlikviewserver: This license key has expired!

 

Cause

The maintenance data for the license key has expired prior to the release date of the product version you are updating too.

See the Maintenance contract on upgrade for more details. 

Example:

000000000000000
NUMBER_OF_USERCALS;5;;
NAMED_CAL_BY_MACHINE_ID;NO;;
PRODUCTLEVEL;10;;2016-12-30
000000000000000

 

In this example, the maintenance contract has expired in 2016. Any QlikView release after this date cannot be licensed with this key.
 
 

 

Resolution

  1. Verify your license first by reviewing if the LEF includes the correct maintenance date. See How to request a control number and LEF.
  2. Update the license on the server prior to the upgrade. See Lef expires or Lef expired displayed in QlikView Management console alert banner on steps to follow.

If the maintenance date is correct and you have attempted to update the license, verify if no old LEF.txt files are stored in your system. See Where do all the QlikView LEF files go? for information on where they are stored. Carry the check out on all nodes if you have a multi node environment. 

If you do not have an up-to-date maintenance date, contact your Qlik Account Manager to renew the license and repeat steps 1 and 2 above.

 

Labels (3)
Comments
Sebastian_P
Partner - Contributor II
Partner - Contributor II

Hi,

what to do in case of Dual Use? i get info that there is no valid maintenance contract. 

Is it possible that License Service cannot connect to a License Backend Service

Or maybe is better to upgrade QlikSense first - they have common Signed Key? 

Sebastian

 

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @Sebastian_P 

Always verify that the license backend is available, yes. 

The Qlik Sense instance in this scenario should not have any impact on QlikView. If you get this message in QlikView when you attempt to upgrade and the license looks OK based on this article (and the license server is available) it may be necessary to contact support through chat and have the license verified on the backend.

All the best,
Sonja 

Version history
Last update:
‎2022-11-02 06:14 AM
Updated by: