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Qlik Sense - Reload Monitoring Apps failed with Error: Table 'tempDateTimeList' not found

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Bastien_Laugiero

Qlik Sense - Reload Monitoring Apps failed with Error: Table 'tempDateTimeList' not found

Last Update:

May 27, 2021 11:10:35 AM

Updated By:

Andre_Sostizzo

Created date:

Mar 20, 2017 5:40:26 AM


In Qlik Sense, the reload of the Operation and License Monitor apps fail with...

"Error: Table 'tempDateTimeList' not found".

You can find this information from the QMC in the script logs.

Environment:

Qlik Sense Enterprise on Windows , all version

Cause:


In a multi node environment there is some steps to configure the monitoring applications correctly in order to find the information across the nodes but also getting all the logs on those nodes. 
In a single node environment there are usually issues with the .txt and .qvd files in the Sense\Log folder (ProgramData) that are causing reload issues.

Resolution:

 

Note: For more updated information on proper configuration visit Configuring the Monitoring apps 

If it's a multi-node environment, do the following: 

  1. Share the Qlik Sense folder on the central node.
    The default location is C:\ProgramData\Qlik\Sense.

  2. Update the data connections ServerLogFolder and ArchivedLogFolder by replacing C:\ProgramData\Qlik\Sense with the path to the shared folder.

  3. Share the Qlik Sense folder on each Rim node.
    The default location is C:\ProgramData\Qlik\Sense.

  4. Add a new data connection for each rim node. This can be accomplished by opening an app, accessing the data load editor, and creating a new data connection. If you have five RIM nodes, you need to create five data connections.
    For example, the data connection for RIM1 points to folder \\rim_node_1\c$\ProgramData\Qlik\Sense\Log and is called RIM1.

  5. Rename the new data connections in the QMC to remove the (username), which is appended to the data connection name. Example: RIM1 (user_183) is changed to RIM1.

  6. Update the load script of the Operations Monitor in section SUB logFolderList on line 5 by adding the names of all the new data connections created in step 4 and 5.
    Each new data connection name needs to be enclosed in single quotes (') and separated by a comma. Example: FOR each node in 'ServerLogFolder','RIM1','RIM2'.

  7. Perform step 6 in the License Monitor. Finally, go to the Hub and open any app. This will generate new .txt and .qvd files in the Sense\Log folder of the Central node, which is often the cause, just because some tables in the database are empty.



If it's a single-node environment, first verify the error. If the Script Reload Logs resemble the following:


  2018-01-25 10:37:35      resident tempDateTimeList
  2018-01-25 10:37:35      Error: Table 'tempDateTimeList' not found
  2018-01-25 10:37:35      Execution Failed
  2018-01-25 10:37:35      Execution finished.

Option1:

  1. This is likely due to the .qvd file and the .txt file being corrupt or missing from the Sense\Log folder, or the files that exist are for an older version and didn't get updated
  2. To fix, delete the .qvd file and .txt file for the specific monitoring app that will not reload. Reload the app again. Also try just opening an app in the Hub and try to reload again. This usually occurs because some tables in the database are empty. If the issue is still not fixed, customer must upgrade to the latest version as this will replace the monitoring apps and source .qvd and .txt. files. (or

Option 2: In the Qlik Sense App script, Change db_v_file_override = 0 to db_v_file_override = 1

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Last update:
‎2021-05-27 11:10 AM
Updated by: