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Qlik Sense Hub and Management Console show "Not Found HTTP Error 404. The requested resource is not found."
May 14, 2021 1:25:16 PM
Oct 19, 2015 4:01:23 AM
Qlik Sense Enterprise on Windows was installed and the installation successful, but neither the Qlik Management Console (QMC) or the hub will open.
Qlik Management Console displays error:
Not Found HTTP Error 404. The requested resource is not found.
Note that for the above, Qlik Sense Proxy service was not reached.
For instances where the Proxy service is reached but returns a 404 with a Qlik Sense log displayed on the returned page as the example below....
... please see How to approach Qlik Sense Error 404 Not Found The following URL is unknown for Hub and QMC
Cause:
It is caused by port conflicts. Proxy Service cannot listen to port 443 or 80 because the two ports are occupied by something else.
Proxy logs may read the following if there are other port conflicts in the environment besides for the apparent conflict on port 443.
https://127.0.0.1:4242 is not reachable.
Here is a detailed explanation:
URL https://<hostname>/qmc or https://<hostname>/hub includes following information:
- This request is sent to port 80 (when http is used) or port 443 (when https is used) of <hostname>.
- The service who is listening to port 80 or 443 on <hostname> should know what /qmc and /hub stand for and answer the requests accordingly.
- If the service who is listening to port 80 or 443 on <hostname> does not know what /qmc or /hub stands for, it returns 404 error.
In a normal environment, port 80 and 443 should be listened by Proxy Service of Qlik Sense, which knows what /qmc and /hub stand for.
It is possible that some other services occupied port 80 and 443 before Proxy Service could do so. Those services, which are not provided by Qlik Sense, do not know what /qmc and /hub stand for. Hence 404 error is returned.
Note: finding out what service is currently occupying port 80 or 443 is not always straightforward and needs to be handled by user's system admin instead of Qlik Support.
Typically, the following command can show which process is using port 443 or 80:
netstat -a -n -o | findstr ":443 :80"
Resolution:
- Verify that the services are all up and running. Attempt a service restart.
- If a restart does not resolve the issue, it is likely caused by an active port conflict, in which case the solution is to stop the conflict by either disabling the current service occupying port 443/80, or configuring Proxy Service to use other ports.
Workaround
Verify if port 443 and/or 4242 are already bound in the system by 3rd party software by opening a Windows Command line (cmd) and running:
netsh http show urlacl
Search for port 443 and port 4242 and if necessary delete those entries with the following commands:
netsh http delete urlacl url=https://+:443/ netsh http delete urlacl url=https://+:4242/
After deleting the port bindings, restart the Sense services. Now the services can have different ports bound, or the other software be uninstalled/reconfigured. More detailed solutions below.
Permanent Solution
Please install Qlik Sense Enterprise to a dedicated Windows server. Please uninstall other application that uses Port 443.
Temporary Solution
Suppose, SQL Server is using port 443. Stop SQL Server services. That would free up port 443.
- Restart “Qlik Sense Repository Database” service. It will restart most of the Qlik Sense services.
- Open QMC (using port 443), CONFIGURE SYSTEM > Proxie
- Select Node “Central” and press Edit or double click.
- Toggle Ports to show PORTS section
- Choose your desired port. We will use port 444 for our demonstration.
- Now, you can use the Qlik Sense Management Console and Hub with port 444:
https://[servername]:444/qmc
https://[servername]:444/hub

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Hi @Andre_Sostizzo ,
Even after deleting thate bindings will it cause any issues to access hub or qmc .
Thanks in Advance!
Regards,
Raju