Under the new Worker service logs available starting on the June 2020 release of Qlik Alerting, the following may be registered: (under C:\ProgramData\QlikAlerting) ... 13 20200611T162538.952+0200 QAServerName 4.0.0 Global ERROR License not active ...
Environment:
Qlik Alerting, June 2020
Qlik Sense Enterprise on Windows, all versions
Cause
Qlik Sense Enterprise Signed License Key (SLK) did not contain the qlikalerting attribute when alerts were first configured via the Web Portal.
Resolution
The issue may be related to licensing of the Qlik Alerting product.
As of June 2020 the licensing is performed by adding the qlikAlerting attribute to the Qlik Sense Enterprise on Windows license. Here are three ways to check if the license has the attribute or still needs to be updated:
If the necessary attribute is in fact missing, once it is added and refreshed in the Qlik Sense server, at this time the best approach for getting Qlik Alerting to start scanning for Alert conditions is to perform a system reboot. Restarting the Qlik Alerting services may be attempted as well.
II. If using a Signed License Key (SLK) and the serial number is not displayed in your version of Qlik Sense:
1. On the Qlik Alerting server, open cmd with Administrator privileges. 2. Run the following:
cd C:\Program Files\Qlik Alerting\setup\license-check npm start
3. The command should retrieve the SLK definitions, display it in the command prompt window, and store it to the rawFile.json file. 4. If the SLK file has qlikalerting attribute with correct sub-attributes, the content of the file licenseFile.json will be similar to the following:
5. The string isActive": true, indicates that the license is active for Qlik Alerting. If false is seen in this line it will explain the reason there is not scanning happening on the server. This state may continue even after the Qlik Sense license is updated. At this time it has been found that the best approach for getting Qlik Alerting to start scanning for Alert conditions is to perform a system reboot. Restarting the Qlik Alerting services may be attempted as well but not be successful.
If the necessary attribute is in fact missing, once it is added and refreshed in the Qlik Sense server, at this time the best approach for getting Qlik Alerting to start scanning for Alert conditions is to perform a system reboot. Restarting the Qlik Alerting services may be attempted as well.
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