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Sonja_Bauernfeind
Digital Support
Digital Support

nlparser_r.exe error in Windows Event log

Last Update:

Oct 3, 2023 4:14:53 AM

Updated By:

Sonja_Bauernfeind

Created date:

Apr 1, 2020 4:08:02 AM

The release of Qlik Sense February 2020 introduced the ability to ask natural language questions in the Insight Advisor, using Natural Language Processing (NLP) Please see the release notes.

The method in this article is only applicable in Qlik Sense Enterprise on Windows versions prior to February 2023 releases. 

Users may notice the following errors in Windows Application Event with the introduction of this new capability:

Faulting application name: nlparser_r.exe, version: 0.0.0.0, time stamp: 0x5d24a292 Faulting module name: _pywrap_tensorflow_internal.pyd, version: 0.0.0.0, time stamp: 0x5d8fe37a Exception code: 0xc000001d Fault offset: 0x0000000004d7f94a Faulting process id: 0x584 Faulting application start time: 0x01d606439acd036d Faulting application path: C:\Program Files\Qlik\Sense\NLParser\nlparser_r.exe Faulting module path: C:\Program Files\Qlik\Sense\NLParser_pywrap_tensorflow_internal.pyd Report Id: 9e3f09df-4ea5-4005-9e83-3d5283be2c92 Faulting package full name: Faulting package-relative application ID:

On systems with a limited amount of RAM, the nl_parser may also consume too much memory for the system to manage and needs to be disabled.  

 

Cause:

To use Natural Language Processor (nlparser_r.exe), CPU must support AVX instructions.  AVX is required by Tensorflow official builds

Please refer to https://en.wikipedia.org/wiki/Advanced_Vector_Extensions#CPUs_with_AVX  to find the supported model or use this utility https://docs.microsoft.com/en-us/sysinternals/downloads/coreinfo to verify if AVX instruction set is supported on the server.

Resolution:

It's not enough that the server supports AVX instructions. They need to be explicitly enabled .

To enable them you can:

  1. run and administrative command prompt and execute: bcdedit /set xsavedisable 0
  2. restart the server

(the setting can be disabled if necessary with " bcdedit /set xsavedisable 1 ")

If the machine runs in Hyper-V, the setting "Allow migration to a virtual machine host with a different processor version" needs to be unchecked.

As the Natural Language Parser requires resources to work, and it's an important functionality in Qlik Sense the long-term resolution is to increase the resources available on the machines where the issue is happening. Please note that this will include servers using the Proxy service, as that is the service opening the connections to the nlparser_r.exe .

Should that not be possible, the workaround for the short term is to disable the functionality, while more resources can be allocated. 

To disable the NLP functionality, for example, if experiencing the above errors in Windows Event log or if nl_parser_r.exe is consuming too much memory on systems with a limited amount of RAM, do the following to turn off nlparser_r.exe. 

Note: This needs to be done on every node in a Qlik Sense cluster where the Proxy service is running, and it will result in the functionality described here being disabled. This will not disable the ability to ask a question under the Insights area, but the system's natural language interpretation will be turned off.

  1. Stop all Qlik Sense services (or close Qlik Sense Desktop)
  2. Edit capabilities.json:
    Qlik Sense Desktop: C:\Users\{user}\AppData\Local\Programs\Qlik\Sense\CapabilityService\
    Qlik Sense Enterprise: C:\Program Files\Qlik\Sense\CapabilityService\" (or corresponding non-default location)
  3. Back-up the file capabilities.json 
  4. Add or change the following flag, if it already exist (as an administrator). Make sure to separate value pairs with comma (,) and enclose within the existing rectangular brackets ([]):
    {"contentHash":"cf15d72343be5e4223b9e8de37e69aef","originalClassName":"FeatureToggle","flag":"NLU_INSIGHTS","enabled":false}
  5. Edit services.conf
    Qlik Sense Desktop: "C:\Users\{user}\AppData\Local\Programs\Qlik\Sense\"
    Qlik Sense Enterprise: "C:\Program Files\Qlik\Sense\ServiceDispatcher\" (or corresponding nondefault location).
  6. Back-up the file services.conf and add "Disabled=true" in the [nl-parser] and [nl-broker] sections.
    [nl-parser] Disabled=true
    [nl-broker] Disabled=true
  7. Start all Qlik Sense service

    DisableNLP_inQS.gif
NOTE: Make sure to use lower case when setting values to true or false as capabilities.json file is case sensitive.
To fully disable Insight Advisor (including the graphical user interface), see Insight Advisor Chat not showing in Qlik Sense Hub.
Labels (1)
Comments
QFabian
Specialist III
Specialist III

Hi @Sonja_Bauernfeind !, do you know when we are going to be able to ask in other language different than english?

 

Greetings!

monjay07
Contributor II
Contributor II

Thanks @Sonja_Bauernfeind ,  Is there a way to configure the nlparser to use TLS1.2 and higher?  We are getting rid of TLS1.1 protocol, however it seems that nlparser is still communication with TLS1.1 protocol.

Best regards

Daniele_Purrone
Support
Support
Daniele_Purrone
Support
Support

Hi @monjay07 : the fix for TLS 1.2 was introduced in September 2020. Which version are you currently on?

monjay07
Contributor II
Contributor II

Thanks @Daniele_Purrone . I see, our versions are before your fix - June 2019 and April 2020.

Daniele_Purrone
Support
Support

@monjay07 : good to know. Once you'll have updated you'll be safely protected by TLS 1.2 😊

Version history
Last update:
‎2023-10-03 04:14 AM
Updated by: