Skip to main content
Announcements
Have questions about Qlik Connect? Join us live on April 10th, at 11 AM ET: SIGN UP NOW

Qlik Sense: NLP Does not work due to missing Basic Constraints in certificate

No ratings
cancel
Showing results for 
Search instead for 
Did you mean: 
Sonja_Bauernfeind
Digital Support
Digital Support

Qlik Sense: NLP Does not work due to missing Basic Constraints in certificate

Last Update:

Aug 25, 2020 2:56:55 AM

Updated By:

Sonja_Bauernfeind

Created date:

Feb 4, 2020 12:21:25 PM

After upgrading to Qlik Sense February 2020 or newer from a previous version, the Natural Language Processing (NLP) feature in the Insight Advisor produces an error such as "Unable to generate insights - Please try again later." How can a check be done to confirm the issue described here Recreating Qlik Sense root CA certificate (script based back-up and removal of existing certificates...?

Environment:
Qlik Sense February 2020

 

Cause:


Qlik Sense February 2020 upgraded its node.js component, which is enforcing validation on certain required certificate constraints. A Qlik Sense Root certificate generated in releases prior to June 2019 do not contain the Basic Constraints "Subject Type=CA" as part of the certificate's Critical Extensions, which causes validation to fail.


 

Resolution:


In order to confirm whether the current installation is affected by this change, run the tool located here https://github.com/StevenJDH/C2-Validator in the Releases section, which will automatically check whether the installed Root certificate meets the needed requirements. The same check can be performed manually using the following steps:

  1. Open the Local Machine/Computer certificate store.
  2. In the Trust Root Certification Authorities section, double-click on the internal Qlik Root certificate.
  3. Under the Details tab for the certificate, filter by Critical Extension Only.
  4. Finally, check that Basic Constraints attribute, and make sure it contains both of the following values "Subject Type=CA". If it does not, then this certificate is affected by the change.


To fix the certificate, please follow the steps described here Recreating Qlik Sense root CA certificate when upgrading to June 2019 and above (script based back-u... under the Solution section to correct the problem.

Labels (1)
Contributors
Version history
Last update:
‎2020-08-25 02:56 AM
Updated by: