While attempting to run the backup or restore, the message "This app can't run on your PC" which would indicate a compatibility issue.
This may or may not have occurred after getting the error "Manager has stopped working" originally.
The file C:\Program Files\NPrintingServer\Tools\Manager\Qlik.Nprinting.Manager.exe is found to be 0KB in size.
Environment:
Cause:
Executable files may become corrupt for various reason such as file corruption due to virus scan locks or disk issues.
The Manager may appear to be hung due to lack of space in the c: drive, corrupt database, incorrect postgres superuser credentials, restrictive antivirus agents, among other potential reasons. Killing the Manager respective process while in apparent hung state may corrupt the file.
Reviewing the C:\ProgramData\NPrinting\Logs\nprinting_manager.log file may lead to further clues.
Resolution:
The file Qlik.Nprinting.Manager.exe has become corrupt.
Removing the file and running a repair NPrinting installation may resolve the issue. Otherwise, the file may be transferred from another installation of a matching product version.
To repair:
- Go to the Windows Control Panel and Installed Programs
- Locate Qlik NPrinting
- Repair the Installation
If no repair option is available:
- Download the identical version installer
- Execute the installer
- Select Repair as the option
To replace the file:
- Locate the Qlik.Nprinting.Manager.exe on a machine with an identical version installed
- Copy the working version
- Replace the damaged file