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NPrinting backup and restore: "This app can't run on your PC" and "Manager has stopped working"

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Andre_Sostizzo
Digital Support
Digital Support

NPrinting backup and restore: "This app can't run on your PC" and "Manager has stopped working"

Last Update:

Mar 10, 2022 9:26:26 AM

Updated By:

Sweta_Sharma

Created date:

Sep 11, 2019 8:56:10 AM

While attempting to run the backup or restore, the message "This app can't run on your PC" which would indicate a compatibility issue.

This may or may not have occurred after getting the error "Manager has stopped working" originally.

The file C:\Program Files\NPrintingServer\Tools\Manager\Qlik.Nprinting.Manager.exe  is found to be 0KB in size.

Environment:

  • NPrinting November 2018

 

Cause:


Executable files may become corrupt for various reason such as file corruption due to virus scan locks or disk issues.


The Manager may appear to be hung due to lack of space in the c: drive, corrupt database, incorrect postgres superuser credentials, restrictive antivirus agents, among other potential reasons. Killing the Manager respective process while in apparent hung state may corrupt the file.

Reviewing the C:\ProgramData\NPrinting\Logs\nprinting_manager.log file may lead to further clues.

 

Resolution:


The file Qlik.Nprinting.Manager.exe has become corrupt.

Removing the file and running a repair NPrinting installation may resolve the issue. Otherwise, the file may be transferred from another installation of a matching product version.

To repair: 

  1. Go to the Windows Control Panel and Installed Programs
  2. Locate Qlik NPrinting
  3. Repair the Installation
    If no repair option is available:
    1. Download the identical version installer 
    2. Execute the installer
    3. Select Repair as the option 

To replace the file:

  1. Locate the Qlik.Nprinting.Manager.exe on a machine with an identical version installed
  2. Copy the working version
  3. Replace the damaged file
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Version history
Last update:
‎2022-03-10 09:26 AM
Updated by: