Description:
- Logged on to the NPrinting WebConsole and editing or opening an NPrinting report template leads to:
- Method Not Found and Address Violation errors
Environment:
- NPrinting all supported versions
Cause:
- Faulty or corrupted installation
- Version of NP designer does not match the version of NPrinting Server that is running in your environment
- Overly aggressive antivirus has quarantined your NPrinting program files causing file corruption and unexpected NP designer behavior. See Qlik NPrinting Server and Designer Anti Virus Folder Exclusions
Resolution:
Note: before proceeding, ensure that the NPrinting Designer setup/installation file is the same version as the NPrinting server. https://help.qlik.com/en-US/nprinting/Content/NPrinting/DeployingQVNprinting/System-requirements_des...
- Uninstall NPrinting Designer
- Delete the installation folder (usually in "C:\Program Files (x86)\NPrinting\Designer"),
- Reboot the computer and install Qlik NPrinting Designer again.
- Do a right click over the NPrinting Designer setup file
- Qlik the General Tab and click 'unblock' if visible
- Next right click again and select 'Run as Administrator' and complete the installation to recommended default folders