Operating monitor and License monitor no longer reload, script logs end with Error: Connection not found: ServerLogFolder
Article Number: 000081522 | Last Modified: 2019/08/21
Description
The monitoring and operations monitor reloads stop working and when you look at the script log for the tasks they end with
Error: Connection not found: ServerLogFolder
Cause
The ServerLogFolder data connection has either been removed, or is no longer accessible by the sa_scheduler account, which is the account used to run reloads.
Resolution
Log into the QMC
Go to Data connections and confirm that the ServerLogFolder data connection is present.
If it is present, then there is an issue with the security rules that is resulting in the sa_scheduler account being unable to access the data connection. We can fix this by creating a new rule that gives the scheduler access to all data connection.
Open Security Rules
Click Create New
Select Data connection access as the template
Fill in the form with the following
Name: sa_scheduler Data Connection Access
Description: Scheduler account needs access to all data connections for reloads.
Resource Filter: DataConnection_*
Actions: Read
Conditions: ((user.name="sa_scheduler"))
Context: Both in hub and QMC
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