QlikView charts with borders 'lose' their borders when inserted as an image in a QlikView Report
Article Number: 000081470 | Last Modified: 2019/10/28
Description
Description of the reported issue:
Beginning with the November 2018 version, NPrinting will not render the borders around QlikView charts, even if the chart in the QVW has a border.
This is due to a code change starting with November 2018.
The purpose of this article is to document a possible work-around to make borders show up in the resulting NPrinting report. In order to do this, its necessary to re-create the report in Pixel Perfect:
Environment:
Qlik NPrinting November 2018 version and later versions
Cause
In versions prior to November 2018 NPrinting uses the borders surrounding chart objects from QlikView. However, beginning with NPrinting November 2018 this is changed so that this no longer occurs (even if the 'Chart' option has been checked under User Preferences > Export Settings)
Resolution
Suggested Workaround:
Create a new report with same App, and choose Pixel Perfect for the type.
Save the report, edit the template.
Add the necessary chart objects to the 'images' section on the left.
Add the image to the report.
Right-click on the object > Properties.
Change the 'Sizing' behavior to 'Auto-Size' so the chart renders at the correct size.
Set border options under the 'Appearance' section (set same color etc. to match the border in the QVW if desired).
Preview and check results.
Get Answers
Find Answers
Qlik Community
Collaborate with over 60,000 Qlik technologists and members around the world to get answers to your questions, and maximize success.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.