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Qlik Sense - Management Console (QMC) and Hub are not accessible

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Bastien_Laugiero

Qlik Sense - Management Console (QMC) and Hub are not accessible

Last Update:

Jun 10, 2021 8:05:04 AM

Updated By:

Sonja_Bauernfeind

Created date:

May 17, 2021 3:28:17 AM

The Qlik Sense Hub and Management Console are not available.  Below are two commonly seen issues including solutions.

 

Environment

 

Connection to QRS Database times out

The Qlik Sense Repository Service does not start. The platform is not available. 

In C:\ProgramData\Qlik\Sense\Log\Repository\Trace\<hostname>_System_Repository.txt you can find the following error:

Fatal exception A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond??Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. Server did not respond within the specified timeout interval.

 

Resolution

  1. Verify that the connectivity to the Qlik Sense Repository Database is working. See Installing and Configuring PGAdmin 4 to access the PostgreSQL database used by Qlik Sense or NPrinti...
  2. Increase the timeout at startup:
    1. Stop all Qlik Sense services
    2. Open C:\Program Files\Qlik\Sense\Repository\Repository.exe.config ( this is the default location, this might be different if Qlik Sense was installed to a customized path)
    3. Find the row with this value:  <add key="DatabaseCommandTimeout" value="00:01:30" />
    4. Change the value from "00:01:30" to to a higher number that works for the specific environment. For example double the value until the issue is resolved.
      • Format is: hh:mm:ss
      • NOTE: The value 0 means unlimited and effectively disabled the timeout function. This should never be applied in a production environment.
    5. Save the file
    6. Start all Qlik Sense Services
    7. Repeat the steps on all your nodes. 

 

Cause 

At service startup, the Qlik Sense Repository Database gets loaded into the Qlik Sense Repository Service memory. 

For large database it is possible that the default 90 seconds timeout is not enough. 

 

The SSL connection request has failed

 

Windows Event Viewer shows the following error message in the 'System' logs:

An TLS 1.2 connection request was received from a remote client application, but none of the cipher suites supported by the client application are supported by the server. The SSL connection request has failed.

 

Resolution

This is an environmental issue.

The client needs to check their TLS (Schannel) Protocol ciphers. They would need to ensure that SHA and other ciphers that are needed are in place so that the error goes  away. Generally this is the responsibility of the network security. 

The Services will need to be restarted and produce no further schannel errors.
The QMC will start (barring no further issues exist). 

See Unable to connect to QMC or Hub after disabling TLS 1.0 and 1.1 .

 

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Last update:
‎2021-06-10 08:05 AM
Updated by: