How can I delete an entry of the TaskExecutionHistory from the QMC?
Article Number: 000072890 | Last Modified: 2019/04/24
Description
I have a faulty entry in the TaskExecutionHistory list in the QMC. I would like to remove this entry. How is this possible?
Environments:
QlikView 11.20 and up
Cause
Faulty entry in the TaskExecutionHistory
Resolution
In the QMC navigate to Status -> Tasks -> select with left mouse click the task in question
On the right frame navigate to the tab "Task Log". Search for TaskID (at the beginning of the log 5th entry) like for example: (2019-04-24 10:32:50) Information: TaskID=dfe723c1-8d11-41ee-803d-4a7748d9ae94
With this TaskID navigate to the folder C:\ProgramData\QlikTech\DistributionService\TaskExecutionHistory There you find XML documents. Every task has it's XML document with it's TaskID in the name like for example: TaskExecutionHistory_dfe723c1-8d11-41ee-803d-4a7748d9ae94
Edit the XML file of the task in question with for example Notepad, there you find following syntax:
The entries between <TaskExecutionHistoryItems> and </TaskExecutionHistoryItems> represent the entries in the Task History of the task in the QMC. You can identify the entry in the XML file corresponding to the corrupt entry in the QMC Task History with for example the value of "Execution Started" in the QMC which corresponds to "StartTimeStamp" in the XML document. Or you can check also with the value "Duration" and/or "Task Status". Delete the entry/line of the XML document corresponding to the entry of the Task History according to the timestamp and/or duration and/or task status.
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