QlikView documents (.qvw) are reverted to an older version causing incorrect data, reload failures, and missing objects.
Article Number: 000071289 | Last Modified: 2019/04/10
Description
QlikView documents (.qvw) are reverted to an older version causing incorrect data, reload failures, and missing objects.
Environment:
QlikView all versions
Cause
One possible cause from an administrative perspective, is if the .qvw source or distributed files were backed up to specific location, and then QlikView got pointed to that(those) location(s) instead of the currently updated and available one.
Resolution
There is no reason to suspect QlikView server will be caching older versions of the .qvw file in memory and then suddenly start rolling back files that were updated multiple times to those supposedly "indefinitely cached" file versions. QlikView Server does cache views from the users until those views hit a point where they are removed to make space for newer versions.
QlikView does not hold in cache old document version(s) indefinitely. It will keep documents open while they are being accessed only and after data is reloaded the opened document instance is replaced with the newly reloaded one. There is an exception though, if in the Management Console\System\Setup\QlikView Server resource\Documents tab settings, the "Allow Only One Copy of Document in Memory" checkbox is unchecked, then there could be multiple versions of a particular app in memory until all user sessions expire in a given version and the document timeout is reached.
Logs from QlikView may be utilized in the investigation, but the cause (if identifiable with help of the logs) for the rollback will more than likely be found to either be environmental or due to setup or administrative changes. These logs would need to be collected with a rollback occurrence timestamp in mind.
From a troubleshooting stand point, would be interesting to see what timestamp the reverted files had for "Last Modified", as well as what version of QlikView had updated the files last. (can be seen when document is opened with QV Desktop > Help > Document Support info...) This information may help investigating if different versions of QlikView Desktop clients (from different developers) or QlikView Publisher to reload apps may have created issues as well, going back and forth between versions multiple times has been known to cause corruption and leading to the impression of rollback when app data or objects go missing/corrupt due to backwards compatibility issues.
It may also be advisable to review any backup/restore scheduled procedures and policies, Antivirus, monitoring services, or any other locally installed agents. If the source documents are not stored locally, this investigation needs to be also performed at the share physical storage location.
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