QlikView: when Digital Certificate is used, QMC fails to connect to other services after an upgrade
Article Number: 000069771 | Last Modified: 2019/03/25
Description
Scenario:
QlikView Server environment using Digital Certificate authentication(as opposed to AD Group authentication)
Upgraded recently
Symptoms:
Since upgrade, QMC reports some services are down(orange bar on top) even though those services are up and running in Windows
The corresponding ports are listening and bound to the correct certificate(issued to hostname and issued by "QlikViewCA")
Despite the certificate bindings, the services' URL in QMC(http://<hostname>:<port>/<servicename>/Service) can only be accessed by HTTP(abnormal) but not HTTPS(normal)
Cause
When Digital Certificate authentication is used, "UseWinAuthentication" in .exe.config files are set to "false". However, upon upgrade, this setting may be overwritten and require a manual change. Detailed mechanism on how this could happen is still under further investigation.
Resolution
Follow these steps:
Identify the services(QVWS, DSC or QDS) that are shown "down" in QMC
Locate the associated .exe.config files. Default locations:
Open the corresponding .exe.config file and look for key "UseWinAuthentication". If it is set to "true"(which is wrong as this deployment is supposed to NOT use Windows Authentication between services), do following:
Stop this service
Change the value of "UseWinAuthentication" from "true" to "false" and save the file(may need to use Text Editor as Administrator)
Start this service
Head to QMC and see if the service is now connected
If above steps still could not fix the problem, please provide following information to Qlik Support
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.