After upgrade to QlikView 12.30.20100 custom URL http://Servername/qlikview/login2.htm cannot be opened via IE and it's plugin after login with credentials user get blank page without error message. With Chrome and Edge it is working normal.
Article Number: 000067704 | Last Modified: 2019/03/12
Description
Environment: QlikView 12.30.20100
After an update from QlikView 12.0 SR7 to November 2018 SR1, the htm page of URL http: //ServerName/qlikview/login2.htm does not work correctly in Internet Explorer. The page is called, you can enter user and password, it does not load after a click on Submit or Enter, no error message just a blank page. This error only occurs in Internet Explorer, on Edge or Chrome it works.
When invoking the login2.htm page, Internet Explorer switches to Document mode IE 7 (if you press F12 after calling up the page and click on tab "Emulation" and then look at what is shown at the bottom frame under Mode). If you switch the page manually (via the drop down) to another Document mode (IE 11 or Edge) then the login works.
However, this is only a temporary change, with the next call the old mode is active again. Has to do with the document type in the header.
Cause
Default Document mode of login2.htm was configured to 7 instead of 11. AccessPoint logon pages of QV 12.30 need to be opened with a browser which represents all the latest standards and features IE11 supports in order to be able to logon and display applications in the browser.
Resolution
You can find the different logon pages on the QlikView server here: C:\Program Files\QlikView\Web Open the respective htm page not working with IE with an editor and add following highlighted bold line to the header of the htm page and save the same:
<head> <!-- Use Internet Explorer 11 Standards mode --> <meta http-equiv="x-ua-compatible" content="IE=11"> <title>QlikView - AccessPoint</title> </head>
Get Answers
Find Answers
Qlik Community
Collaborate with over 60,000 Qlik technologists and members around the world to get answers to your questions, and maximize success.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.