Why Do The NPrinting 16 Server and Designer require a QlikView Desktop to be installed
Article Number: 000062951 | Last Modified: 2019/01/24
Description
Description:
Some customers are asking why the NPrinting Server and NPrinting Designer requires the QlikView desktop to be installed on the NP 16 server.
Cause
Cause:
NPrinting 16 server and designer sends API commands to the QlikView desktop where the QlikView Desktop does all the report processing and thus all the actual heavy lifting and work when generating NPrinting reports
NPrinting server: QlikView desktop must be installed to receive the API commands from the NPrinting Server to process NPrinting reports.
NPrinting designer: QlikView desktop must be installed to receive the API commands from the NPrinting Server to process NPrinting reports.
NOTE: NPrinting 16 is planned for permanent support deprecation by End of March 2020. Please consider evaluating NPrinting 18 and or higher versions prior to then. Please reach out to your Qlik Account manager for more information on receiving trial licenses for NPrinting 18 and higher versions.
Resolution
Resolution:
NPrinting 16 Software (server and designer) both require the QlikView Desktop to be installed in order to generate NPrinting reports
NPrinting sends API commands to the QlikView desktop in the background in order to generate NPrinting reports from QlikView QVW datasource.
This concept is covered in NPrinting Training courses available through the Qlik Support portal here: https://www.qlik.com/us/services/training/qlikview-training
Additional Training resources available in the Qlik Community:
NPrinting Training Material online: https://community.qlik.com/t5/Qlik-NPrinting-Documents/QlikView-NPrinting-16-Training-amp-Installation-Upgrade/ta-p/1489063
NP 16 Tutorials by subject: https://community.qlik.com/docs/DOC-14618
Get Answers
Find Answers
Qlik Community
Collaborate with over 60,000 Qlik technologists and members around the world to get answers to your questions, and maximize success.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.