Users working in the Qlik Sense HUB are prompted for credentials multiple times
Article Number: 000057534 | Last Modified: 2018/10/10
Description
This issue is seen in Qlik Sense Enterprise version April 2018.
After implementing SSO users using the Qlik Sense Hub are receiving a pop-up asking for credentials each time when opening an app. This was not happening before.
While they are able to get to the app the multiple pop-ups asking for username and password are annoying.
Environment: Qlik Sense Enterprise April 2018
Cause
The issue has been seen in the April 2018 release after implementing a complex SSO IdP. Prefixed virtual proxies are making calls to prefix-less default virtual proxy and results in multiple credential requests.
It has NOT been reported in other releases.
Resolution
In the default Central virtual proxy in the QMC, add a prefix.
NOTE: Be careful doing this, it will change how the system is accessed, for example; adding the prefix of 'win' will change the access from/to: FROM https://www.<FQDN>.com/QMC TO https://www.<FQDN>.com/win/QMC
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SECOND: The data connections for the Monitor Apps, as seen below, will also have to be updated to include the prefix else the monitor tasks will fail.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.