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Report Preview or Task fails with error "...Parameter name: Column not found..." or "Column Not Found"
When running a report either via a publishing task or via On-Demand, the report may fail with the error below registered:
In the NP Engine logs:
Engine.Navigator.Qlik.xx resolution ended unsuccessfully with exception System.Exception: Specified argument was out of the range of valid values.??Parameter name: Column not found
In the NP Scheduler logs:
Qlik.NPrinting.Repo ERROR: System.Exception: Specified argument was out of the range of valid values.??Parameter name: Column not found
NPrinting Designer Preview:
Environment:
- Qlik NPrinting All Supported Environments
Cause:
"Column not found" refers to a column that has either been replaced, deleted, or renamed on the source app (.qvw / .qvf) and no longer matches the used column from the NPrinting Report Template Table objects.
Resolution:
- Reload the metadata for the connection
- Right-click the table or column itself in the object list pane and click "Update"
- Re-add the object by Right-clicking 'Tables' in the object list pane.
- Insert the updated table or column tag into the NPrinting Template
If the object is updated, the used tags on the report template will need to be replaced with the new tag representing the updated columns
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