What is seen in NPrinting previewed reports and NPrinting logging
- When there is no data in the report after applying the report filters, the task fails with error similar to the following:
...
Failed generation of report xxxxxxxx-xxxx-xxxx-xxxxx-xxxxxxxx for user xxxxxxxx-xxxx-xxxx-xxxxx-xxxxxxxx. ERROR: Cannot apply filter Filters: [Fields: [Name: F\X, ConnectionId: xxxxxxxx-xxxx-xxxx-xxxxx-xxxxxxxx, Values: [String:x], Override: False, Void: False, Name: F\Y, ConnectionId: xxxxxxxx-xxxx-xxxx-xxxxx-xxxxxxxx, Values: [String:y], Override: False, Void: False], Void: False], Bookmark: , Void: False to current document data. Requested fields with evaluates are:
...
Environment:
Cause:
What is the cause of this?
- When the combination NPrinting object, report, task and user filters (as per NPrinting filter rules) results in null values in the report, the task is expected to fail with similar error mentioned in the description. Note that Error logging details may differ depending on the version of NPrinting in use.
- If the 'filter' is applied at the chart object in the NPrinting template editor, and it if the chart produces null values, the report can still be produced if the option "Generate report. Invalid content will be replaced with placeholder images" is enabled.
- See section 'Configuring Report Behavior' in the following link for details Filters - Qlik NPrinting
- The option "Generate report. Invalid content will be replaced with placeholder images" is available from NPrinting April 2018 release and later versions only. To leverage this feature, you must upgrade to a version of NPrinting that contains this feature
Resolution:
Solution to manage these errors: