On Demand Report Errors Out When Accessing a QV Cluster - Logged BookMark errors
Article Number: 000052749 | Last Modified: 2019/07/10
Description
The following Qlik NPrinting behavior and log errors are found with Qlik NPrinting Cluster connections to QlikView cluster server
ON demand reports are not working and eventually generate an error message. The first attempt to generate an On Demand report is successful but subsequent attempts fail in a clustered QV environment.
Error in Engine Log:
Qlik.NPrinting.Engine 18.x.x.x Qlik.NPrinting.Engine.Consumer.ContentRequestExecutor 20180518T101918.941-07:00 WARN TESTSERVER1 0 0 a0461e2b-1ead-4843-87d0-a451ddec5afa 0 a7565877-0a49-4b3b-848f-1ddfefdeae31 0 832be4e8-bbce-43d3-b373-2b48758192bd 0 Exception while processing request 832be4e8-bbce-43d3-b373-2b48758192bd : Bookmark with id Server\BM0X-XX could not be found
Cause
In a QlikView clustered server environment, bookmarks are not shared/visible between clustered QlikView servers so when a second NP report is generated, the effect of clustering lands the request on a different QV server than the original QV server.
The second QV cluster node/server does not have the bookmark needed which resided on the original QV server and results in subsequent failed NPrinting On Demand reports.
Resolution
Current workaround:
As a workaround until the issue can be permanently resolved, we suggest continuing to use NPrinting QVP server connections to a single QlikView node in the cluster rather than using QlikView cluster connections.
! This is currently being investigated as a defect, and actively being worked on. Information provided on this defect is given as is at the time of documenting. For up to date information contact support at support.qlik.com with the ID QV-17700 for reference. The previous fixed added to QlikView 12.2 S 6 has not resolved the issue for all customers and may still appear sporadically as a result even after upgrading to QV 12.2 SR 6.
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