QRS API gets different migration status of an application than what shows in Qlik Sense Management Console
Article Number: 000050527 | Last Modified: 2018/11/21
Description
Symptom:
The user sees "Migration failed" from QMC -> Apps -> Migration status
The user calls QRS API endpoint "GET /qrs/app/{appid}/state" to query the migration state according to the help page, and gets ""appIsEnabled":true", which means it is successfully migrated.
Environtments:
Qlik Sense: all versions
Cause
There has been a time out during the app migration process, where QRS didn't receive migration successful response from the Migration Service in time. Therefore QRS marks "StatusValue" = 2 under "AppStatus" table in QRS database, which represents Migration Failed. This is where the QMC gets the Migration status.
Sometimes, the migration is actually successful after the QRS communication has timed out. The app has been successfully transformed for the current version, and the correct "MigrationHash" has been generated and stored in the "Apps" table in the QRS database. In this case, the response for the "GET /qrs/app/{appid}/state" call will return ""appIsEnabled":true".
Resolution
The API response of "GET /qrs/app/{appid}/state" tells the real fact about the app migration status.
The status shown in QMC indicates there has been an error (most likely time-out) happening during the migration process, but the app is not necessarily failed being migrated. For verifying the result in QMC Migration status, user can query "/qrs/appstatus" and parse using the AppId.
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