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Qlik Sense hub shows error tunneling socket could not be established, cause=getaddrinfo ENOTFOUND

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Andre_Sostizzo
Digital Support
Digital Support

Qlik Sense hub shows error tunneling socket could not be established, cause=getaddrinfo ENOTFOUND

Last Update:

Jun 21, 2021 3:34:43 PM

Updated By:

Jin_Park

Created date:

Apr 13, 2018 3:07:47 AM

When opening the Qlik Sense hub, the following error is displayed: 

Error requesting "https://_:4242/qrs/license/" - Error: tunneling socket could not be established, cause=getaddrinfo ENOTFOUND 80808080:80

1.png

However, the Qlik Sense logs are relatively clean during this time.

Only log files in C:\ProgramData\Qlik\Sense\Log\HubService shows the same message repeatedly:

6    20180409T133219.753+1000    ServerName    0.15.8    Global    INFO    Requesting GET https://ServerName:4242/qrs/license/, referrer /license/
7    20180409T133222.053+1000    ServerName    0.15.8    Global    ERROR     [ Error requesting GET https://ServerName:4242/qrs/license/ ] - Error: tunneling socket could not be established, cause=getaddrinfo ENOTFOUND 8080 8080:80

 

Cause:

Proxy Service is accessing Repository Service via URL https://ServerName:4242.

This connection respects the Proxy Settings in Environment Variables. Any limitations caused by the environment proxy settings will prevent service communication.

 

Resolution:

 

  1. Run the batch file in Windows Commands To Retrieve Environment Information on Qlik Sense servers that are running Proxy.exe
  2. Inspect "Environment Variable" section in the result files.
  3. Find out whether following variables exist:
    • HTTPS_PROXY
    • HTTP_PROXY
  4. If they do, contact Windows Administrator and remove them. Restart the server.

Important: There might be settings automatically add these variables back to the server after a restart or certain time period. Should that happen please contact Windows Administrator to resolve.

  1. Access the System Properties in Control Panel > All Control Panel Items > System
  2. Advanced system settings 
  3. Under “Advanced” tab > Environment Variables 
  4. Under system variables tab delete: “HTTPS Proxy” & “HTTP Proxy” 
  5. Restart the server
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Last update:
‎2021-06-21 03:34 PM
Updated by: