Can you force a password change in QlikView when using DMS mode or DMS mode with Custom Users?
Article Number: 000048284 | Last Modified: 2018/11/21
Description
Can you force password changes in QlikView using DMS mode, or DMS mode with Custom Users?
Environment :
QlikView, all versions
Cause
There is no way to force a password change in DMS mode with custom users, so this could be considered a limitation of that particular functionality.
Resolution
Custom Users are saved in an .xml database on disk (passwords encrypted). The Custom Users directory connector has no feature built in to allow for an automated, or forced, change of passwords. If a "Custom Users" like functionality is required in the environment, we recommend building a more tailored SSO solution for the specific requirements.
DMS mode can be used without Custom Users, with authentication still being done through NTLM. Password change policies for the Windows domain apply to any user authentication. DMS and NTML mode cannot be mixed.
Custom authentication/ Custom Users and NTLM can be mixed in a QlikView environment configured to use DMS mode, but require two webservers, one for Custom User authentication, one for NTLM authentication.
Get Answers
Find Answers
Qlik Community
Collaborate with over 60,000 Qlik technologists and members around the world to get answers to your questions, and maximize success.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.