NPrinting SMTP - Email fails When Using Anonymous Authentication
Article Number: 000047619 | Last Modified: 2018/09/07
Description
When using an SMTP server which is configured to allow " Anonymous Authentication " the email fails.
You receive "Email not sent. Check your email configuration." when using the Send test email button
The NPrinting scheduler logs also show: "Failed to send email"" 5.5.4 Unrecognized Authentication type "
Environments:
NPrinting 17.6 and up
Cause
Incorrectly specifying a username and password for an SMTP server that allows Anonymous Authentication. This is a change in the email authentication mechanisms since NPrinting November 2017.
Resolution
If you are using an SMTP relay server that usesAnonymous Authentication you do no need to specify a username and password in the NPrinting email settings, leave these fields blank. Try to send the email again.
As an example to configure SMTP settings in the NPrinting Webconsole for an SMTP server using Anonymous Authentication:
Go to Admin >Settings > Email Settings
Name: A name of your choice Address: The full address of your SMTP server Port: 25
Username: leave this blank Password: leave this blank
Default sender email: The email address you want the emails to come from. Test email address: Your own email address to test with.
Get Answers
Find Answers
Qlik Community
Collaborate with over 60,000 Qlik technologists and members around the world to get answers to your questions, and maximize success.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.