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NPrinting Designer error: Interface Not Supported
Oct 12, 2021 8:10:32 AM
Dec 11, 2017 1:18:05 PM
When opening the NP designer results in three consecutive error messages. However, in some environments no errors are seen and the Designer process and the Microsoft product process (i.e. Excel, Word, etc) will remain in hung state when inspecting via Task Manager. The follow errors are the result:
- Interface Not Supported
- EAccess Violation
- Access Violation
Environment:
- Qlik NPrinting NPrinting 17.x.x track
Cause:
In some networks, network policy is defined in such a way that prevents users to fully behaving as an administrator on a Windows Server even when that user is added to the local administrators group on the NP Windows 2008 or 2012 R2 server. By using the new manually created "Run as Administrator' short cut, the user is allowed by the operating system to successfully open the NPrinting Report Template editor.
Resolution:
This message can have a number of different root causes:
Outdated NPrinting Version
If you are on an old version of NPritning (pre 17), upgrade.
Incomplete or corrupted installation of NPrinting or QlikView
- Re-install NPrinting. Remember to run the setup file as an administrator ( right click on the setup.exe file and choose "run as administrator").
- Re-install QlikView or executed the repair procedure
Incomplete or corrupted Office Installation
If the issue persists, you may also need to perform the MS office repair procedure as well. Here you can find a link you can follow for this: https://support.office.com/en-us/article/Repair-an-Office-application-7821d4b6-7c1d-4205-aa0e-a6b40c...
A reboot is required after each possible solution.