Skip to main content

How To Check Invalid Username/Password For Oracle Database Connection

No ratings
cancel
Showing results for 
Search instead for 
Did you mean: 
Daniel_Seo
Support
Support

How To Check Invalid Username/Password For Oracle Database Connection

Last Update:

May 27, 2021 3:26:51 PM

Updated By:

Andre_Sostizzo

Created date:

Dec 6, 2017 7:18:41 PM


When connecting Oracle database using native ODBC or Qlik ODBC&OLE DB connector package, the following error message show up.
So, we need to check if the username/password is valid.

        000043205a.jpg

 

 

Environment:

 

Qlik Sense Enterprise on Windows , all versions

Cause:


Login denied due to invalid username/password

 

Resolution:


Option #1. Creating UserID, changing Password and giving a permission, these are Oracle DBA roles. So you can ask DBA to check invalid userID.
 
Option #2.  Check sqlplus connection between Oracle client and database server
   1. Open CMD (Windows command prompt) on Qlik Product server
  
   2. Move to c:/ directory
      C:\Document and settings\ORANGE> cd\
  
   3. Set Oracle SID
       C:\> set oracle_sid=<DB name>
              e.g C:\> set oracle_sid= "Oracle DB Name" {press enter}
  
   4. Login using sqlplus
       C:/ sqlplus <UserID>/<Password>@"Oracle_SID" 

      If you know sysdba password, you can use the following commend
       C:\> sqlplus /nolog {press enter}
              sql:\>connect sys as sysdba {press enter}
                        password : sys {press enter}
              sql:\> connected
              sql:\> connect <UserID> {press enter}
                        Enter password :tiger {press enter}
              sql:\> connected

 

Labels (2)
Contributors
Version history
Last update:
‎2021-05-27 03:26 PM
Updated by: