Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE

On-Demand button for NPrinting is not visible in QlikView AccessPoint

No ratings
cancel
Showing results for 
Search instead for 
Did you mean: 
Frank_S
Support
Support

On-Demand button for NPrinting is not visible in QlikView AccessPoint

Last Update:

Aug 23, 2021 4:45:34 PM

Updated By:

Frank_S

Created date:

Dec 6, 2017 6:03:53 PM

NPrinting On-Demand for QlikView is installed but is not appearing in QlikView AccessPoint.

 

Environment:

  • Qlik NPrinting 
  • QlikView Unsupported versions ie: Qlikview 11.20 SR 15 or SR16 from Qlikview 11.20 SR 13 and below

 

Cause:

  • Missing MIME types after upgrade to Qlikview 11.20 SR 15 or SR16 from Qlikview 11.20 SR 13 and below in QlikView QMC>QlikView Web Servers>Web tab.
Extension Content
.JSON application/json
.TTF application/x-font-truetype

 


IIS Cause:
Missing MIME types after upgrade to Qlikview 11.20 SR 15 or SR16 from Qlikview 11.20 SR 13 and below.

Mime types are:

Extension Content
.JSON application/json
.TTF application/x-font-truetype

 

Resolution:

  1. Upgrade to most recent supported versions of QlikView and NPrinting

----------------------------------------------------------------------------------------------------

If still on unsupported versions, you can use the following. However these are for unsupported products and therefore are now unsupported steps/workarounds:

If the following has already been confirmed proceed to next steps below:
- 
Specific browser's cache has already been cleared after installing On-Demand
- The file "C:\Program Files\QlikView\Server\QlikViewClients\QlikViewAjax\htc\addons\config.json" contains information pertaining to how to connect to the NPrinting server.
Example:
...
{"addons":[{"active":true,"config":{"apiPath":"/api/v1","certificateThumbprint":"","server":"https://<NPrintingServerFQDN>:4993","useProxy":false},"name":"nPrintingOnDemand","script":"on-demand-addon.js"}]}
...


- The QlikView NPrinting On-Demand plugin has been installed on all QlikView WebServer (QVWS) / IIS nodes.

If AccessPoint is hosted by QlikView Web Server (QVWS) please see the steps below:
-Go to the QMC, System tab > Setup and click on "QlikView Web Servers" in the tree. Then click on the Web tab to the right
-Scroll down the mime types list and see that .JSON and .TTF types are missing
-Add these to the mime types list in the Webserver

Extension Content
.JSON application/json
.TTF application/x-font-truetype


Note: This solution is only for Qlikview with a QVWS. 

1.png


If AccessPoint is hosted via IIS, see steps below to resolve the issue:

Add the JSON and TTF as MIME types in IIS. This can be done by: 

1.  Open IIS manager > Default Web Site > MIME Types
2.  Look for .json and .ttf MIME types in the list. If such entries are not found, add the following entries:

  • Extension: .json ; MIME type: application/json
  • Extension: .ttf ; MIME type: application/x-font-truetype

2.png

3.png

3. Restart the IIS Web Server and all NPrinting Services

 

NOTE: If you have a supported version of QlikView and you have the same issue even if you have the correct mime types, please clear your browser cache entirely and restart your browser

 

Version history
Last update:
‎2021-08-23 04:45 PM
Updated by: