Metadata reload and task execution in NPrinting 17 and 18 is extremely slow or fails. Bookmark issue.
Article Number: 000042985 | Last Modified: 2019/09/30
Description
The reload of metadata has become extremely slow and may fail after a long time. The problem may occur only for some connections. It is possible that other connections, even connecting to the same source document are faster. After enabling Interactive Service Detection it may be observed that QlikView Desktop UI does not show up in session 0 even though a qv.exe instance is shown active with memory usage oscillation in windows task manager. Recently, this issue has also been see to cause the NPrinting Engine to Crash.
In the NPrinting Engine logs, error(s) similar to the one below may be registered: ... Qlik.NPrinting.Engine 17.4.0.0 Qlik.NPrinting.Engine.Consumer.BlockingContentResolver 20190627T165853.815-04:00 WARN KKSVNPRINTING 0 0 0 0 0 0 0 0 Error while waiting consumer task and deleting navigator bookmark. ERROR:Object reference not set to an instance of an object. Stack trace: ...
Environment:
NPrinting 17.3 / November 2017 / February 2018
Cause
Product Defect ID
OP-4261
Resolution
Fix Version:
NPrinting April 2018 and later versions
Diagnose:
Check that folder. If the size of the files is over approximately 1MB:
Workaround fix:
NPrinting creates some bookmarks files in this folder in the NPrinting Engine machine:
C:\Users\NPRINTING ENGINE USER NAME\AppData\Roaming\QlikTech\QlikView\Bookmarks
A bookmark file is created for each connection and they are used to speed up the generation of metadata. If the size of these file increases too much (more than 1 MB), they became difficult to manage and they may block the metadata reload or cause severe performance decrease. In particular, opening the source application or applying filters become really time consuming or may fail.
Steps to Resolve the issue:
Stop the NPrinting Engine service
Remove the bookmark(s) from the folder
C:\Users\NPRINTING ENGINE USER NAME\AppData\Roaming\QlikTech\QlikView\Bookmarks
Restart the Engine service
Reload the NPrinting metadata
Performance should now be restored.
or
Upgrade to the most recent version of NPrinting
Get Answers
Find Answers
Qlik Community
Collaborate with over 60,000 Qlik technologists and members around the world to get answers to your questions, and maximize success.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.