Qlik Sense - Database restore - Fatal exception There are multiple accounts for the following user: INTERNAL\sa_repository
Article Number: 000034062 | Last Modified: 2018/11/22
Description
In Qlik Sense, after a database restore, you cannot start the Qlik Sense Repository Service.
In the logs (By default C:\Programdata\Qlik\Sense\Log\Repository\Trace\System.log) you find those errors:
24 20170515T115434.725+0200 ERROR QlikServer1 System.Repository.Repository.Core.Security.UserManagement.UserManager 9 bae68cc0-7a42-4a66-9abd-756e6cf2ac8e DOMAIN\qvservice Multiple entries for user INTERNAL\sa_repository found in the user database bae68cc0-7a42-4a66-9abd-756e6cf2ac8e
25 20170515T115434.741+0200 ERROR QlikServer1 System.Repository.Repository.QRSMain 9 466ab7c6-f59c-4cd9-b7ab-9fffad4127cd DOMAIN\qvservice Fatal exception There are multiple accounts for the following user: INTERNAL\sa_repository at Repository.Core.Security.UserManagement.UserManager.GetUser(String userDirectory, String userId)↵↓ at Repository.Core.Security.UserManagement.TransientUserCache.Get(String userDirectory, String userId)↵↓ at Repository.Core.Security.Privileges.ElevatedPrivileges.GetSuperUser()↵↓ at Repository.Core.Security.Privileges.ElevatePrivileges()↵↓ at Repository.Core.Core.Setup()↵↓ at Repository.Core.Core.Inner(ManualResetEvent shutdownRequestedEvent)↵↓ at Repository.QRSMain.<Main>b__35_2(ICore core)↵↓ at Qlik.Sense.Common.Ioc.WorkScope.Work[T](Action`1 action)↵↓ at Repository.QRSMain.Main() 466ab7c6-f59c-4cd9-b7ab-9fffad4127cd
Cause
This issue might occur because you didn't drop the database before restoring it. To properly restore a Qlik Sense Database you need to have a completely empty database instance to restore to. To do that you will need first to drop the existing database, then create a new one and finally proceed with the restore.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.