Description:
While attempting to start the NPrinting services, the following errors may be displayed:
Windows could not start the Qlik NPrinting Engine service on Local Computer...
Followed by...
I.
Error 1053: The service did not respond to the start or control request in a timely fashion.
II.
Error 1067: The process terminated unexpectedly
III.
Error 1069: The service did not start due to a logon failure
Cause:
For the errors above respectively:
I.
This indicates a problem starting the service that may or may not be related with the service account itself.
II.
This usually indicate that the NPrinting service account does not have local administrative rights, which is a requirement.
III.
This may be due to the NPrinting Service account not having Log on as a Service local rights.
Resolution:
For the causes listed above respectively:
I. Change the Qlik NPrinting service to use a dedicated domain service account for NPrinting. Then see II. and III. below, and if the issue persists you can also try extending the Windows SCM timeout value. See How to extend Windows SCM default timeout of 30 seconds
II. Use a local administrator account on all applicable Qlik NPrinting services. E.g. Make sure the service account is a member of the Local Administrators Group of the Qlik NPrinting server.
III. Check and add if does not have Log on as service:
1. Go to Local Security Policy (Start > search for Local Security Policy), or under Start > Run, type secpol.msc.
2. Under Local Policies -> User Rights Assignment
3. Search by scrolling to Log on as a service
4. Add the service account if does not exist
5. Restart the NPrinting Services.