NPrinting 17 and QlikView QVP connection: changing app objects causes NPrinting metadata generation to get stuck in status "Generating"
Article Number: 000029602 | Last Modified: 2018/06/12
Description
Changing app objects causes Nprinting meta data generation to get stuck in "Generating" When this occurs, users can no longer generate metadata for this app. After adding or removing an object from the app, the user saved the app, without reloading the app in QlikView.
If the app is not reloaded by the Qlikview server after a change in the app layout, this means that the QVS does not have the same version of the app in the RAM and the version stored on disk.
PS: This is only applicable when the user connects to the document using the QVP connection in NPrinting.
Cause
After adding or removing an object from the app, the user saved the app, without reloading the app in QlikView.
If the app is not reloaded by the Qlikview server after a change in the app layout, this means that the QVS does not have the same version of the app in the RAM and the version stored on disk.
PS: This is only applicable when the user connects to the document using the QVP connection in NPrinting.
Resolution
This is working as designed.
Since NPrinting queries the document via a qvp connection and in the case that the document is not reload by the qvs after the app change was made, the QVS does not have the app change reflected in it's cache hence causing the cache generation in NPrintingto fail
To work around the generating status the user should kill the qv.exe process in the task manager on the NPrinting server. PS: NPrinting may retry the connection, so more qv.exe process may reappear after killing the all qv.exe processes, you should kill the qv.exe processes multiple times till they no longer appear, and you see a cache generation error in NPrinting.
Reload the document using the Qlikview server, then retry the meta data generation in NPrinting again.
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