Article Number: 000027702 | Last Modified: 2018/06/12
Description
The UDC fails to sync successfully and sits in a 'starting' state indefinitely, or success after a long period of time (>10mins) but no user attributes has been updated
This has been experienced through User Directory Connectors:
- Excel (via ODBC) - SQL (via ODBC)
Error message shows in C:\ProgramData\Qlik\Sense\Log\Repository\Trace\<ServerName>_UserManagement_Repository.txt
E.g
_synchronizing all users for c826fb6d-b191-4cf4-98d3-5d448185008a was not successful *An item with the same key has already been added.*_
Restart server (services), recreated the user directory connector will not resolve the issue above.
Cause
This is a known issue QLIK-71060 in Qlik Sense version 3.0.4, it should works fine in 3.1 SR1 and 3.0.3
Resolution
The problem occurs when a user have attributes with the same value but in different types
For example:
userid=01 has one attribute type Stream and one attribute type Connection, both with same value All
This will result the error message show the same key has already been added message in log.
Workaround: make sure that the attribute names are distinct per user and then delete the user from Sense and resync the user directory connector.
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