QlikView License Violation Detected: engine will be disconnected error in NPrinting 17
Article Number: 000018123 | Last Modified: 2019/10/28
Description
You get this error message in the Engine logs even if the user has a named CAL license assigned manually. It is not possible to start the Engine from NPrinting Server. It stays off-line or shows Error.
Cause
Some letters are added before the [Settings 7] line in the QlikView Settings.ini file. NPrinting cannot find this line and the information about the leased license.
Resolution
NPrinting Engine needs a licensed QlikView Desktop application on the machine where it is installed. It is possible to license QlikView with a full license or assign it a Named CAL from the QMC. When the Engine is started, the QlikView license is checked. In case you are working with a Named CAL, NPrinting looks for the Settings.ini file saved in %appdata%\QlikTech\QlikView.
The file must contain the row
LeasedLicenseExpiry= ExpirationDate, StartDate
You must verify that the expiration date is in the future.
Any errors in the settings.ini file can block the Engine. It is possible that, for some reasons, QlikView adds some letters before the [Settings 7] paragraph, like in this case:
. . . DlgPos28598=521,237 DlgPos29054=481,162 DlgPos253=628,365,645,641,0 DlgPos336=279,192,842,441,0 DlgPos29030=416,236 [Ql[Settings 7] InterfaceLanguage = English InstalledLIBID110 = {15B258E8-415E-11D1-934D-0040333C91CC} CanDynamicUpdate = 1 Utf8FileDlgPathOpenDoc = D:\QlikView\Desarrollo\CM Calidad\2.Aplicación Test\ MarginTop = 20 LeasedLicenseExpiry = 2016-05-07 13:53:26, 2016-04-07 13:53:26 . . . You see that [Ql has been added before [Settings 7]. It is necessary to remove these letters and save the settings.ini file to resolve the problem.
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