Not Able To Open Section Access Protected QlikView Application (QVW) File After Upgrade
Article Number: 000005581 | Last Modified: 2018/06/12
Description
After system upgrade Section Access protected QlikView application file can not be accessed. The user gets access denied message from QlikView Server or QlikView Desktop client.
Commonly either of the below changes have been made during the upgrade:
QlikView server machine name changed
Domain name changed
Domain user name changed
QlikView Server authentication method changed
QlikView Server directory service changed
New QlikView license number has been applied
Moving data sources to different location (either file or database)
Renaming data sources (either file or database)
Cause
System changes have made the Section Access user credentials invalid in the system, and thereby access is being denied for users.
Resolution
Depending in the Section access setup, there can be different options to recover the access to the QlikView application.
Using Strict Exclusion to limit user access Move data source can lead to missing data, leading to strict exclusion locking user out from application 1. Revert to old QVW that contains data 2. Correct the script to fit the new data source setup
Using NTNAME as Section Access credential Changed domain or machine name can make previous NTNAME value obsolete. 1. Access the file with an other user that is still valid, for example USERID value if such exists 2. Restore machine or domain name to make SA user valid 3. Rename machine to old domain name to mimic old domain to unlock section access
Using SERIAL to lock Section Access to specific license number User access tied to license number will fail in new license is applied 1. Use other user not linked to license, to unlock and edit the script 2. Change license back to previous number
Using NTSID as Section Access credential The NTSID is fetched from the local Windows, the logon will fail if the NTSID is incorrect or missing 1. Access the file with an other user that is still valid, for example USERID value if such exists 2. The NTSID has to be restored in Windows, if only NTSIDs are used in Section Access,
Get Answers
Find Answers
Qlik Community
Collaborate with over 60,000 Qlik technologists and members around the world to get answers to your questions, and maximize success.
Experiencing a serious issue, please contact us by phone. For Data Integration related issues please refer to your onboarding documentation for current phone number.