Article Number: 000004067 | Last Modified: 2018/06/12
Description
Server bookmark made by users, stops working after a while. No selection is made in the QlikView document, when the bookmark is applied. Enabling “Always One Selected Value” can lead to current bookmarks no longer working. This article explains why and how to resolve the issue.
Environments:
Qlikview Server 11.20
Cause
If a list box has had ‘Always one selected’ after the bookmark is created it is not enough to just remove the list box in question. ‘Always one selected’ is a field property and not a list box property. The check box that can be seen in the list box properties dialogue is so to speak a shortcut. To remove the ‘Always one selected’, this option has to be unchecked in the list box properties dialog.
A way to see what a bookmark contains is to look at the xml-file of the bookmark. Here all selections and settings of list boxes at the time of the bookmark creation are included, so it is a way to determine what list box did not have 'Always one selected' when the bookmark was created. To get the file, you can export the bookmark in question from the document, and you will then get an XML-file.
Resolution
When a bookmark is created it takes a snapshot of the document’s state at that particular point in time. Any list box that has ‘Always one selected’ checked is also included in the bookmark. If a list box gets this option checked after the bookmark has been created the bookmark can no longer be applied correctly. This is because the bookmark is trying to apply ‘none selected’ which contradicts the ‘Always one selected’. This is as designed.
The workaround for this is to set ‘Apply on top of current selections’ when creating a bookmark. If "Apply on top of current selections" is activated then all possible selections would be applied and the "impossible ones" would be ignored.
Or to create a new bookmark with the same selections as the old bookmark had.
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