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Extranet License: QlikView Server does not allow all documents to be loaded or documents do not appear on the AccessPoint

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Troy_Raney
Digital Support
Digital Support

Extranet License: QlikView Server does not allow all documents to be loaded or documents do not appear on the AccessPoint

Last Update:

Nov 10, 2020 6:19:58 AM

Updated By:

Sonja_Bauernfeind

Created date:

Feb 11, 2013 3:32:57 AM

The QlikView AccessPoint is not showing all documents and/or when a document is loaded it fails with Failed to load  document, you do not have access.

  • This issue involves QVWs that are listed in the User Documents list of the QlikView Management Console, but either do not show in the AccessPoint or cannot be opened when clicked irrelevant of the user account is used.
  • The Windows permissions on the file(s) is correct, the user(s) has the appropriate permissions and CALs needed to view and open a document, but the QVW does not appear; or the incorrect QVWs are shown in the Access Point.


Environment:

  • QlikView any version 

 

Cause:


This occurs when using a QlikView Extranet license, or having a limitation in the License Enabler File (LEF) similar to the example below. This restriction sets the number of documents that can be displayed in the Access Point.

After this type of license is applied, if the settings are not set manually, the first documents opened in the Access Point will automatically fill up these document slots until the limit is reached. The QlikView Server will apply the availability limitation setting to the document until it is removed manually. 
This means that if a demo application is opened after the initial installation, and later that demo QVW file is deleted or removed, one of the number of available documents will still be taken up by that demo document.

Example of a QlikView Extranet License LEF file:
 

DISABLE_COLLABORATION;YES;;
FORCE_AUTHENTICATION;YES;;
LICENSE_LEASE;NO;;
NAMED_CAL_BY_MACHINE_ID;NO;;
NUMBER_OF_DOCUMENTS;3;;
NUMBER_OF_SESSIONCALS;5;;
PRODUCTLEVEL;10;;2014-08-01
WORKBENCH;YES;;

 

Resolution:


When using a QlikView Extranet Server license, or any QlikView Server license with a limitation in the License Enabler File (LEF) like the following example: 
 

NUMBER_OF_DOCUMENTS;3;;


There will be a document setting in the QlikView Management Console > Documents > User Documents > select a QVW > Server tab > Availability > Availability Limitations.
 

Availability Limitations.png


This is the setting that allows the document to become available on the Access Point. The maximum number of documents allowed correlates to the number of documents set in the LEF.

Once all of the allotted document availability settings have been applied, this setting will be grayed out on the other QVWs.

Allo document to be loaded.png

If there are fewer documents that can use this setting than there should be, based on the number set in the license, it's possible that a document with this setting has been removed. For example, the license allows for 3 documents to be available on the access point, but the Availability Limitation setting is grayed out for all documents.

In this case, the original QVWs will need to be restored to their original path or new QVWs with the same name and path as the originals should be created so that the Availability setting can be removed.

Alternatively, all previously allowed documents can be cleared by following these steps: 

  1. Stop the Qlikview Server Service
  2. Go to C:\ProgramData\QlikTech\QlikViewServer
  3. Delete FDL.dat
  4. Reboot the server

This will clear ALL the documents out of the list allowed for AccessPoint. You can then go back into the QMC and select the QVWs to display.



If you are looking to restore a CAL previously lost due to this, see: How to recreate out of sync or corrupt CAL data


 

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Last update:
‎2020-11-10 06:19 AM
Updated by: