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Qlik Sense - "Setting up connection to LDAP root node failed. Check log file"

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Sonja_Bauernfeind
Digital Support
Digital Support

Qlik Sense - "Setting up connection to LDAP root node failed. Check log file"

Last Update:

Apr 13, 2021 5:14:59 AM

Updated By:

Maria_Halley

Created date:

Oct 24, 2016 9:27:41 AM

When synchronizing Qlik Sense with Active Directory, you may encounter an error message saying "the User Directory Connector (UDC) is not configured, because the following error occurred: Setting up connection to LDAP root node failed. Check log file"

This often indicates a log on failure, i.e. the username and/or password is wrong.
 

Cause:

A common cause for this is wrong username and/or password.

Resolution:

  1. Attempt to set up the UDC and receive the error message
  2. Go to the the following location to get user management log file: %ProgramData%\Qlik\Sense\Log\Repository\Trace
  3. Locate the QLIKSERVER_UserManagement_Repository_<Date/timestamp>.txt file and open it
  4. Scroll to the bottom of the file
  5. Read the content of the line marked by ERROR
  6. If the error message is related to username and password related, move to the next steps, otherwise file a support case with us
  7. Verify that the user and password actually exists, and that they are in the domain
  8. In the username field, enter the domain name with a "back-slash", it should look like this domain_name\<username>
  9. Enter the password normally.



 

Comments
cluo23
Contributor
Contributor

 

Qlik Sense - "Setting up connection to LDAP root node failed. Check log file"

and the log  StackTrace

at Repository.Users.SafeUserDirectoryConnector.CallWithTimeout[T](Func`1 func, TimeSpan timeout)↵↓ at Repository.Users.SafeUserDirectoryConnector.Setup(Logger logger)↵↓ at Repository.Users.Factories.UserDirectoryFactory.TrySetupUserDirectory(UserDirectory userDirectory)

I can login through LdapAdmin.

Please tell me how to do

Thanks!

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @cluo23 

Please post your query with all additional information (such as symptoms and what you are attempting to achieve) in the open forum. This way you can make use of our active userbase and our active engineers.

This would be the correct forum: Qlik Sense Management and Deployment.

All the best,
Sonja 

andrew_thomson
Contributor II
Contributor II

@cluo23 Hi, did you ever get a resolution to this problem? I am facing the exact same issue with one of my environments.

Thanks in advance.

yshteyn
Contributor
Contributor

I am seeing same error and upon checking the user management repository log, I see the following..

Fetching directoryentry LDAP://brldaps.mydomain.net:636 failed: The server is not operational

However, I validated that the AD is functional as I am able to telnet on port 636 to above host in addition to I am sure I have the correct password (validated)

Please advise, what else could this be?

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @yshteyn 

Port 636 is usually used for LDAPS. The URL you mentioned only uses LDAP. See Requirements to establish Qlik Sense on Windows UDC Connectivity Using LDAPs 

I hope this helps!

If not, I recommend posting on our Deployment and Management forum. I cannot monitor responses to this for the coming week as I will be out of the office, and your question will have a broader reach there.

All the best,
Sonja 

 

Contributors
Version history
Last update:
‎2021-04-13 05:14 AM
Updated by: