Users start seeing the error Connection to Engine Failed for Unspecified Reasons when accessing the hub.
When this starts to occur, it happens consistently until the entire node is restarted, but users accessing applications directly (using a browser bookmark or shared link) are unaffected.
The Qlik Sense configuration has already been verified and Web Sockets are supported. See Hub Error: Connection to Qlik Sense engine failed for unspecified reasons for information.
Environment:
Qlik Sense September 2017
Qlik Sense November 2017
Qlik Sense April 2017
Cause:
The error message is misleading, it indicates that a websocket connection failed, and when accessing the hub the websocket is created against the repository service on the engine node.
This endpoint can fail in some circumstances, leading to the all future websocket establishment failing until the service is restarted, and a misleading error message about the engine.
Resolution:
This is caused by a product defect (QLIK-86030) in the repository service which was fixed in Qlik Sense April 2018.
If the issue persists, verify that the environment supports Web Sockets and that Qlik Sense is correctly configured. See Hub Error: Connection to Qlik Sense engine failed for unspecified reasons.