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NPrinting Services Will Not Start after New installation Nov. 2018 through June 2019 versions of NPrinting Server

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Frank_S
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NPrinting Services Will Not Start after New installation Nov. 2018 through June 2019 versions of NPrinting Server

Last Update:

May 18, 2021 6:15:46 PM

Updated By:

Frank_S

Created date:

Sep 11, 2019 1:32:28 PM

Description of the Issue:

  • Fresh install of a supported version of Microsoft Windows server operating system ie: Windows 2012, 2016
  • Attempting to install NPrinting 19, June 2019 release
  • When installing with a dedicated NPrinting service account, the installation and operation of NPrinting is successful and work normally (services are working as expected)
  • When re-installing - or upgrading - NPrinting (and or NP Engine) with a different/new dedicated NP service account, a problem with certificates is discovered in the NPrinting web engine log files.
Web Engine client certificate not found in store. Generating a new certificate from RabbitMQ CA key
Unable to start WebEngine service. ERROR: System.InvalidOperationException: Found 0 certificates for RabbitMQ Certification Authority
  • NPrinting Engine and NP web engine will be installed normally however the NP Engine and Web Engine services will not start and or fail to remain in a 'running' state.


Environment the issue was discovered:

  • June 2019 release of NPrinting


Environments affected:

  • All versions of NPrinting from November 2018 to June 2019

 

Cause:

  • The use of certificate communication between the NP engine and NP server started with November 2018 release of NPrinting.
  • With the affected versions NPrinting, the installation program is unable to remove certificates associated with previous Windows user account use to install NPrinting with. These certificates must be removed manually,
  • Note: if unable to manually delete the certificate while logged on as a Windows Administrator user account, please contact your Windows Group Policy Domain administrator and advise them of this restriction of Group Policy so they can amend group policy as needed

 

Resolution:

  • Upgrade to the latest version of NPrinting. The has been in place since NPrinting September 2019 release.


Workaround:

  • Uninstall the NP Engine software
  • Open "Manage computer certificates" from the Windows search bar
  • Go to Trusted root Certification Authorities then delete the certificate NPrinting-CA
  • Delete the NP engine in the NP engine manager under Admin>Engine manager in the NPrinting Web Console.
  • Next, re-install the NPrinting Engine software (type/document the certificate password used as you will need it in the next step)
  • Add a new NP engine in the NP engine manager under Admin>Engine manager in the NPrinting Web Console (insert certificate password when prompted)

Community Discussion regarding this issue: 


Related article:

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Version history
Last update:
‎2021-05-18 06:15 PM
Updated by: