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Monitoring Apps fail to reload with Error: DNS error

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Monitoring Apps fail to reload with Error: DNS error

Last Update:

Dec 30, 2020 7:03:25 AM

Updated By:

Andre_Sostizzo

Created date:

Jul 24, 2019 8:27:37 AM


Monitoring Apps fail to reload with the following error in the logs:
...
20201229T150424.304-0300 DNS error
20201229T150424.327-0300 Error: DNS error
20201229T150424.327-0300 DNS error
20201229T150424.332-0300 Execution Failed
20201229T150424.345-0300 Execution finished.
 ...

 

Environment:

  • Qlik Sense Enterprise on Windows, all versions

Cause:

The error is seen if the Data Connection string has an outdated FQDN after changing the Qlik Sense server's hostname, still has the loopback name localhost in a multi-node Qlik Sense deployment,  or DNS issues are ongoing in the environment.

 

Resolution:


Confirm there are no DNS issues ongoing in the environment. (e.g. using ping or nslookup). If so, temporarily updating the Windows OS hosts file may work around the issue.

Otherwise, the issue is resolved by the changing the url and trustedLocations in all the monitor_REST_* Data Connections' connection string to the Fully Qualified Domain Name (FQDN) or server's hostname, instead of the loopback name localhost.  

Any other Qlik Sense Data Connections' Connection string need to be updated to have the 'trustedLocations' and 'url' values in Connection string set to the new FQDN of the Central node. These are listed in QMC under the Data Connections section. See example under How to set up Monitoring Apps in a clustered environment 

 

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Last update:
‎2020-12-30 07:03 AM
Updated by: