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NPrinting Scheduler Service & certain NP User Profiles Stop working with Log Error - Timezone is unknown

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NPrinting Scheduler Service & certain NP User Profiles Stop working with Log Error - Timezone is unknown

Last Update:

Jun 21, 2021 4:39:58 AM

Updated By:

Sonja_Bauernfeind

Created date:

Feb 1, 2019 6:03:32 PM

NPrinting Scheduler log error similar to the following:

  • In the NPrinting Logs: System.AggregateException: One or more errors occurred. ---> Autofac.Core.DependencyResolutionException: An exception was thrown while executing a resolve operation. See the InnerException for details. ---> Timezone Canada/East-Saskatchewan is unknown (See inner exception for details.) ---> System.Exception: Timezone Canada/East-Saskatchewan is unknown
  • This will apply to all recently deprecated time zones as well.

Result:

  • NPrinting Scheduler stops working
  • NPrinting User accounts that contain defunct time zones stop working

 

Cause:


Cause of Issue 

  • Defunct time zones are not automatically updated local time zones in versions of NPrinting prior to June 2019.

 

Resolution:


To work around the issue: 

  • Update the Publish Task Schedule Trigger that contains the defunct time zone 
ie: "Timezone Canada/East-Saskatchewan" and replace it with a valid and available time zone.

  • Update any NPrinting user account to use valid and available Time Zones

To resolve the issue permanently: 

  • Please upgrade to NPrinting June 2019 or later releases.


NOTE: View the NP logs to determine which Time Zone is invalid in the meantime and follow the resolution steps above to fix the problem.

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Last update:
‎2021-06-21 04:39 AM
Updated by: