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NPrinting On Demand Error: No Connection to NPrinting Server - QlikView

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Frank_S
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NPrinting On Demand Error: No Connection to NPrinting Server - QlikView

Last Update:

Sep 28, 2021 12:14:54 PM

Updated By:

Frank_S

Created date:

Oct 9, 2018 12:17:24 PM


When attempting to generate On Demand reports in the QlikView AccessPoint installed on IIS, the Error "No connection to NPrinting server" appears and NPrinting reports cannot be generated.
 

Environment:

Qlik NPrinting , all versions

 

Cause:


1. The QlikView server was not added as a Trusted Origin


2. Ensure that the fully qualified path (and any FQDN alias addresses) for the QlikView Access Point is added as a trusted origin in the On Demand settings on the NPrinting server.

  • End users must then use the fully qualified path to the QlikView server, in this case, to use On Demand without error. All QV accesspoint origin server addresses must be added to the On Demand 'trusted origins' page in the NP web console.

3. QlikView IIS Access point Only: If On Demand breaks after an IIS upgrade from IIS 6.5 to IIS 7.0, check in your browser developer tools (F12 in IE or End and developer tools in Chrome) for a network HAR trace message "406 - Not Accepted" message

 

Resolution:


Do one or all of the following as needed:

Note: Check that On Demand configuration and setup is performed correctly as per the following Qlik Help Link before proceeding below:

  • Enable JWT communication for NPrinting On-Demand with QlikView IIS
  • Installing On-Demand Add-on on a Microsoft IIS hosted QlikView AccessPoint
  • The Qlik NPrinting services Windows domain user account must be a member of the following two groups on the QlikView Server (as well as the AccessPoint server, if the Access Point is installed on a separate Windows IIS access point computer):
    • QlikView Administrators
    • QlikView Management API (this group must be created manually)
  • QVP connections must be used with NPrinting On Demand for QlikView
  • Note: You must restart QlikView and Qlik NPrinting services after adding the Qlik NPrinting services Windows domain user to the QlikView Administrators and QlikView Management API groups.

1. Check to ensure that the QlikView Server Access Point path is added as a trusted origin in the On Demand settings on the NPrinting server. 


For example: http://qlikserver1
- All users must use this trusted origin to access the QV access point server in order to successfully generate On Demand reports


2. FQDN (Fully Qualified Domain Name) paths:

a. Ensure that the fully qualified path (and any FQDN alias addresses) for the QlikView Access Point is added as a trusted origin in the On Demand settings on the NPrinting server.
For example:
http://qlikserver1.qlik.com or if secured use https://qlikserver1.qlik.com and not http://qlikserver1
- All users must use this fully qualified path trusted origin to access the QV access point server in order to successfully generate On Demand reports

b. Modify the config.json file on the QlikView Server for the NPrinting On Demand components so that the NP server path uses a fully qualified path is used 
Within the config.json file found in the folder path below, you will likely find the NPrinting server address:
https://yournprintingserver:4993
Change this to match your QlikView server fully qualified path by appending .qlik.com

For example the updated NPrinting server address will appear in the following format:
https://yournprintingserver.qlik.com:4993

You will find the config.json file in the following path wherever you installed the NP On Demand components (either the QVWS access point or the QV IIS Access Point)
C:\Program Files\QlikView\Server\QlikViewClients\QlikViewAjax\htc\addons
 
 
3. After performing either step 1 or step 2 above, please stop then start the NPrinting Web Engine service.

4. Close then reopen the web browser and navigate to the QlikView Access Point server
5. Select the document that contains your On Demand report and click the On Demand Button. 
6. Error should be resolved as a list of available reports should appear.

 

For additional troubleshooting on this topic, visit the link found in the Related Content section below:


Related Content:

Note: Configuring 3rd party certificates, the QlikView IIS Accesspoint and JWT in NPrinting is in the realm of Qlik Professional services or your preferred Qlik Partner as these are custom implementation options not required for default NPrinting deployments.

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Last update:
‎2021-09-28 12:14 PM
Updated by: