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Message "No matching connections. Check the log files for details." is displayed when importing report to NPrinting

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Andre_Sostizzo
Digital Support
Digital Support

Message "No matching connections. Check the log files for details." is displayed when importing report to NPrinting

Last Update:

Jun 1, 2022 4:10:19 PM

Updated By:

Frank_S

Created date:

Aug 7, 2018 4:29:49 PM

Description:

When importing a report from in NPrinting, the following is displayed:

 

 

No matching connections. Check the log files for details

 

 

Import a new report Connections.png

Environment:

Qlik NPrinting 

 

The Web Engine log shows this error message:

 

 Qlik.NPrinting.Repo.Service.ImportExport.DataConnectionsMatchingService    20180720T164303.260+02:00    WARN    NPServer    User Name    0    0    0    0    0    0    0    0    Trying to import connection ConnectionName. Data connection ConnectionName does not match↓Missing objects from template: O\NtPvx↓  

 

Resolution:

According to the error message in the log above, the import of the report fails because the O\NtPvx object is not present in the Qlik Sense application connected to NPrinting in the new environment.
There is a difference between the objects that the NPrinting report needs and what it can find in the new environment connection.
Here is how the problem can be fixed.

In the original environment:

  1. Duplicate the QVF Sense App and "Publish" the duplicated QVF
  2. Export the Duplicated Sense App (select 'with data' check box).
  3. Change the App ID in the NPrinting Connection to use the Duplicated App ID
  4. Reload the NPrinting connection
  5. Export the NPrinting report.


In the new environment:

  1. Import the Duplicated Sense app you exported from the original environment.
  2. Modify the NPrinting connection to use the duplicated fully published Sense App ID
  3. Import the NPrinting report that you exported from the original environment.

Result: Error should no longer be present

 

Cause

  • During the importing process, NPrinting checks that there is a connection to a Sense application with the same objects used in the report. If the objects are missing (ie: private sheets and objects in the QVF), the NPrinting report import will fail with error
    No matching connections. Check the log files for details
  • So, before importing a report from a different environment, it is necessary to have also a copy of the fully published Sense app used to create the report in the original environment and to create an NPrinting connection to that app.

Best practice:

  • Avoid creating NP reports from unpublished sheets and sheet objects

Requirement:

Comments
TusharDev_Qlik
Creator II
Creator II

@Andre_Sostizzo @

Version history
Last update:
‎2022-06-01 04:10 PM
Updated by: