Skip to main content
Announcements
Have questions about Qlik Connect? Join us live on April 10th, at 11 AM ET: SIGN UP NOW

Unable to open application in the Qlik Sense hub, TlsSocket: Could not retrieve client certificate context. (No client certificate?)

No ratings
cancel
Showing results for 
Search instead for 
Did you mean: 
Bastien_Laugiero

Unable to open application in the Qlik Sense hub, TlsSocket: Could not retrieve client certificate context. (No client certificate?)

Last Update:

May 25, 2021 6:50:57 AM

Updated By:

Sonja_Bauernfeind

Created date:

Apr 20, 2018 4:07:48 AM

Qlik Sense Apps fail to ope on the Hub.

The Qlik Sense Engine System logs log the following error:

43427    20180411T061709.322+0100    WARN    QlikServer1    System.Engine.Engine    110    f28e9cf0-feec-4edc-978f-b3f34a910706    ServiceAccount    QrsPlugin: HTTP connection: read error: connection reset by peer (ECONNRESET)    0    Internal    Engine    20180411T061709.322+0200    7504    5836    20180322T023353.000+0100    f28e9cf0-feec-4edc-978f-b3f34a910706

43428    20180411T061709.337+0100    ERROR    QlikServer1    System.Engine.Engine    61    c3753f87-107a-4651-8426-3643e3049c8b    ServiceAccount    QvSocket: TLS handshake failed with code -2146893007 for [TCP socket 172.30.43.238:4747 <-> 172.30.56.181:49129].    0    Internal    Engine    20180411T061709.322+0200    7500    5836    20180322T023353.000+0100    c3753f87-107a-4651-8426-3643e3049c8b

43429    20180411T061709.384+0100    WARN    QlikServer1    System.Engine.Engine    61    8839a32c-48bb-44ea-80cc-2587e1abc558    ServiceAccount    TlsSocket: Could not retrieve client certificate context. (No client certificate?)    0    Internal    Engine    20180411T061709.384+0200    7500    5836  

 

Environment:

Qlik Sense Enterprise on Windows 

 

Cause:


This problem may occur if Qlik Sense has lost access to the certificate for a different reason: 

  • Certificates corrupted
  • Certificates deletion
  • Certificate files locked

 

Resolution:

 

  1. Restart the Qlik Sense services (or the entire server)
  2. Check if the Qlik Sense certificates are still there following: Confirming certificates using Microsoft Management Console
  3. If the certificate(s) are missing then you can follow the instructions: How to recreate or just delete certificates in Qlik Sense
  4. Make sure every antivirus exclusion are in place Qlik Sense Folder And Files To Exclude From AntiVirus Scanning
Labels (1)
Contributors
Version history
Last update:
‎2021-05-25 06:50 AM
Updated by: