When creating OLE DB or ODBC connection, QlikView Desktop shows one of two possible errors:
Failed to connect to QlikView Connector
or
Failed to unbundle QVConnect
Cause:
QvConnect32.EXE and QvConnect64.EXE (the processes handling 32 and 64-bit OLE DB/ ODBC connections in QlikView) are bundled into C:\Program Files\QlikView\Qv.exe. On the first time the script editor is opened, these QvConnect files will be extracted into C:\Users\<user>\AppData\Local\Temp\QVConnect\<QlikView version>\. This implementation ensures that QvConnect always match the current Qv.exe version.
- If current user has no access to this path, QlikView cannot extract QvConnect files and shows error "Failed to unbundle QVConnect"
- If there is a security protection (such as a group policy or antivirus) that block file execution from this path, QlikView is unable to run these exe files and shows error "Failed to connect to Qlikview Connector"
- QvConnect64.exe and QvConnect32.exe are not digitally signed
Resolution
Verify Permissions
1. Make sure the current user running QlikView Desktop has full access to the path C:\Users\<user>\AppData\Local\Temp\QVConnect\<QlikView version>\
2. If QvConnect32.EXE and QvConnect64.EXE already exist in this path, try to run these exe files to see if there is any error message similar to the followings:
3. If the path needs to be changed, see QvConnect64.exe and QvConnect32.exe are not digitally signed.
Domain Policy or Anti Virus scans
If a similar error message shows up, QlikView is unable to lauch QvConnect due to a group policy restriction or an anti virus scan. Request system or domain administrator to add an exception to this group policy so that QvConnect32.EXE and QvConnect64.EXE can be executed from this path.