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Qlik Sense "Connection lost" error generated by AWS Load Balancer time out setting

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Lisa_Sun
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Qlik Sense "Connection lost" error generated by AWS Load Balancer time out setting

Last Update:

Aug 24, 2020 8:20:04 AM

Updated By:

Sonja_Bauernfeind

Created date:

Dec 12, 2017 10:37:06 PM

After upgrading to Qlik Sense June 2017 or later,  the following error occurs when accessing Qlik Sense hub through AWS Application Load Balancer (ALB). 

User-added image

This happens when loading the data from Data Load Editor. 

'Connection lost. Make sure the QlikSense is running properly. If your session has timed out due to inactivity refresh to continue working.'

Accessing Qlik Sense on the server itself directly works fine.  It only has issues when accessing through ALB. 
 

 

Cause:

AWS Application Load Balancer (ALB) time out.  

 

Resolution:

 

The problem was caused by the AWS Application Load Balancer (ALB) or a similar cloud-hosted load balancer not applying it's the timeout settings correctly.  The timeout settings (set in the management GUI) in ALB were not carried across to actual configuration. Please reach out Amazon for this fix. 

For instance, The ALB settings specified a 30-minute timeout (to match Sense) however the actual configuration in the ALB was still the default 60 seconds.

Timeouts may also be caused by other active network devices, such as firewalls.



 

 

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Last update:
‎2020-08-24 08:20 AM
Updated by: