Attempting to create a Qlik ODBC connection results in either of the below errors.
Error Variant 1:
Connector Issue: Qlik ODBC Connector Package error
The connector dialog can not be displayed.
Make sure the connector is properly installed and compatible with Qlik Sense.
Error Variant 2:
The-connector-dialog-cannot-be-displayed
Make sure the connector is properly installed and compatible with Qlik Sense
Error Variant 2:
GetCustomConnectors -1 Failed to find custom connectors
Fig 1
Environment: Qlik Sense Enterprise for Windows
Cause:
The Qlik ODBC connectors package version is not same on all nodes including service cluster
The Qlik ODBC Connector package backups are causing conflicts in the environment.
Resolution:
1. Verify that connectors are installed
Make sure files for the failing connector are located under the shared 'Custom Data' folder configured in your Service Cluster. To locate the folder, see Service Cluster.
All connectors should be automatically copied to that folder. If you see this error message, verify that the files have been copied and if not manually copy them to the folder.
And also, all nodes should have same connector version, if not make sure to replace the connector package in all nodes (C:\ProgramData\Qlik\Custom Data) including Service Cluster.
2. Backups located in the Custom Data folder
- Remove any backups of the ODBC connector package in the Custom Data folder of your Service Cluster configuration and in nodes (C:\ProgramData\Qlik\Custom Data).
- Restart the Engine and Dispatcher Service.