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NPrinting Server does not run tasks. The same tasks can be run correctly by NPrinting Designer

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Sonja_Bauernfeind
Digital Support
Digital Support

NPrinting Server does not run tasks. The same tasks can be run correctly by NPrinting Designer

Last Update:

Dec 28, 2020 8:23:44 AM

Updated By:

Sonja_Bauernfeind

Created date:

Dec 15, 2016 5:11:27 AM

The schedules are correctly listed in NPrinting Server > Monitoring tool. They are started correctly but the execution process stops. You can see this in the log files:

Source    Date    Time    Type    Message
Service    20/10/2016    09:14:11    Information    Service - QlikView NPrinting Designer
Service    20/10/2016    09:14:11    Information    QlikView NPrinting version: 16.4.0.0
Service    20/10/2016    09:14:11    Information    Log File: C:\Test\Logs\20161020_NPrintingSVC.log
Service    20/10/2016    09:14:11    Message    Loading schedules
Service    20/10/2016    09:14:12    Message    QlikView NPrinting file opened: C:\Test\Training\test.nsq
Service    20/10/2016    09:14:12    Message    QlikView NPrinting file loaded: C:\Test\Training\test.nsq
Service    20/10/2016    09:14:12    Message    External request thread loaded
Service    20/10/2016    09:14:12    Message    On Demand thread loaded
Service    20/10/2016    09:14:12    Message    1 schedules loaded
Service    20/10/2016    09:14:12    Message    Scheduler started
Service    10/20/2016    9:15:00 AM    Message    Service: event started
Service    10/20/2016    9:15:00 AM    Message    Run Schedule: Test schedule
Service    10/20/2016    9:15:00 AM    Message    Run Job: jtest
Service    10/20/2016    9:15:00 AM    Message    Run Task: task


There is no message after Run Task.

The same task can be run correctly using the Designer application.

 

Cause:


The last message in the logs tells that the process stopped opening the QlikView document.

The problem may be due to:

  • An incorrect license assignment. The NPrinting Service cannot run the task if a license is not correctly given.

    NPrinting needs to open the QlikView document in the connection through the QlikView Desktop application. A valid license is needed to to this. You can license the local QlikView Desktop application or you can assign a named user CAL to the NPrinting User.

  • A message that it waiting for a manual answer in session 0.

    NPrinting opens the QlikView document in a graphical session. There may be some message showed by QlikView that must be answered manually. For example, if you add or edit a macro to the QVW, the NPrinting User will be asked to allow the macro. QlikView will wait until it has an answer before working, so it can stop the task execution.

     

Resolution:

 

  1. The best way to troubleshoot the problem is starting the Interactive service detection and access session 0 (see the article that explains how to do this). You will be able to see the QlikView application working in the background and understand immediately what is the problem blocking the execution process:
    • There may be a QlikView warning message complaining that there is not an assigned license. In this case you have to assign a User Named CAL manually from QMC to the NPrinting Service User, as it is stated in the NPrinting requirements.
    • There may be a message that requires a manual answer. For example, you may be asked to enable macros. Answer the question to resolve the issue.
  2. If it is not possible to access session 0, you can open the QlikView document in the connection as the NPrinting Service User.

    To do this:
    1. Access the QlikView installation folder.
    2. SHIFT and right click on Qv.exe
    3. Choose "Run as a different user"
    4. Enter the NPrinting Service User account information in the window that opens.
    5. Open the QlikView document

  3. If the QlikView document is saved on a different machine, be sure that the NPrinting user is a domain user and that have full access to the folder where the .qvw file is stored.

     
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Last update:
‎2020-12-28 08:23 AM
Updated by: