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Failed upgrade of Qlik Sense due to superuser password validation

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Andre_Sostizzo
Digital Support
Digital Support

Failed upgrade of Qlik Sense due to superuser password validation

Last Update:

May 7, 2021 1:33:02 PM

Updated By:

Andre_Sostizzo

Created date:

Feb 26, 2016 8:00:42 PM

 

The error "Superuser password validation failure." is displayed during an upgrade.

wrongSuperUserPassword.PNG

 

Environment:

 

Cause:

There are two known causes:

1. The upgrade failed because you entered an incorrect superuser or repository password during the first upgrade attempt.

Although you inserted an incorrect password, you were still able to create the PostgreSQL 9.6 version of the database, and the wrong password was registered in the settings. Therefore, later upgrade attempts will fail because the passwords in PostgreSQL 9.6 no longer match.

2. For older versions of Qlik Sense, the issue may occur when upgrading Qlik Sense, if all services are stopped, then an incorrect superuser password will cause the install to fail and additionally remove the C:\Program Files\Qlik\Sense\Repository\PostgreSQL directory.

Due to the removal of the directory by the PostgreSQL installer component, there will be no utilities to connect to the PostgreSQL database in order to change the superuser password.
 

Resolution:

For causes 1 and 2 above, respectively:

1. Delete the c:\ProgramData\Qlik\Sense\Repository\PostgreSQL\9.6 folder and try running the upgrade procedure again. Make sure you enter the correct password. For reference see Upgrade fails with message "Qlik Sense Superuser password validation failure" 

 

2. Steps for Cause 2 above:

  1. If this is a multi-node environment, take down all other nodes to prevent syncing between nodes running different versions of Qlik Sense.
  2. Uninstall the current version of Qlik Sense, but do not remove Qlik Sense root and server certificates, and data folders. This will ensure that the Apps, Qlik Sense Repository Database, the self-signed certificates used for inter-service communication, and configuration in C:\ProgramData\Qlik\Sense is not removed.
  3. Rename C:\ProgramData\Qlik\Sense to C:\ProgramData\Qlik\Sense-old
  4. Reinstall the version of Qlik Sense that was previously installed.
  5. Do not allow services to start when the setup is complete:
    User-added image
  6. Once Qlik Sense is installed, rename 
    • C:\ProgramData\Qlik\Sense to C:\ProgramData\Qlik\Sense-reinstall
      • and then rename C:\ProgramData\Qlik\Sense-old to C:\ProgramData\Qlik\Sense
  7. Follow steps in How-to reset forgotten PostgreSQL password in Qlik Sense to alter the superuser password to the password that the customer desires
  8. Bring services back online
  9. Verify that everything looks correct
  10. Run the installer for the upgrade package 
Comments
GordonSimFront
Partner - Contributor II
Partner - Contributor II

GordonSimFront_0-1641847397216.png

 

GordonSimFront
Partner - Contributor II
Partner - Contributor II

When I remove the 9.6 directory I can install.

However when I try to run QLIK the system can't find my domain as it did before.

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @GordonSimFront 

Can you clarify what you mean with Qlik not finding the domain?

GordonSimFront
Partner - Contributor II
Partner - Contributor II
The machine name is “QlikSense2”

The issue is I have “Old” data that I could do with getting back I know it is in the 9.6 directory that I have backed up, If I try to reinstall the installer asks for the details for the repository, however when the install runs it fails because of passwords (I Know that the passwords are right).

So I removed everything and did a fresh install, this worked OK BUT If I replaced the fresh 9.6 directory with my “Old” one I get an error when I try to go to http:\\ QlikSense2\qmc\ saying that it cant find that page.

I only have two questions “Can I get any of the old data back?” if so How?

Regards, Gordon
Sonja_Bauernfeind
Digital Support
Digital Support

Hello @GordonSimFront 

This looks to require additional troubleshooting that we can't provide in the context of this article. I would recommend either posting this in our Qlik Sense Deployment forums or contacting Support.

All the best,
Sonja 

Contributors
Version history
Last update:
‎2021-05-07 01:33 PM
Updated by: