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License or Operations Monitor apps fail to reload with error: Error: Field 'Sequence#' not found

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Andre_Sostizzo
Digital Support
Digital Support

License or Operations Monitor apps fail to reload with error: Error: Field 'Sequence#' not found

Last Update:

Sep 2, 2020 7:33:48 AM

Updated By:

Sonja_Bauernfeind

Created date:

Aug 18, 2015 11:18:35 PM

The reload task fails with a message like this in the document log:

Failed reload log shows errors when loading Archived Logs like:      FROM 'lib://ArchivedLogsFolder/servername\Engine\Audit\XXXX.log'
      (txt, utf8, embedded labels, delimiter is '\t', msq)
      WHERE isnum(Sequence#)
           AND CounterName <> 'Layout' and CounterName <> 'Properties'
Error: Field not found - <CounterName>
General Script Error
Execution Failed
Execution finished.


or

           2017-11-10 10:16:48 0454       WHERE isnum(Sequence#)
            2017-11-10 10:16:48      Error: Field 'Sequence#' not found
            2017-11-10 10:16:48      Execution Failed
            2017-11-10 10:16:48      Execution finished.

or

 

Sequence# field not found in 'lib://SHARE/Repository/Trace/SERVERNAME_Synchronization_Repository.txt' 


The steps below apply where it cannot find any field. The field that cannot be found includes but is not limited to CounterName, ProxySessionID.

Environment:

  • Qlik Sense Enterprise on Windows and Qlik Sense Monitoring apps

 

Cause:

QLIK-35804: Occasionally when Qlik Sense services stop, they do not fully write to the logs in the expected format. 

 

Resolution:

 

Services need a restart

 

Restart the Qlik Sense services 

 

Last stop of services did not write logs in the expected format

 

Modify the License and Operations Monitor apps such that it will continue parsing logs even if it fails to fully parse a particular log.

  1. When logged in to the server, import a new copy of the problematic app from C:\ProgramData\Qlik\Sense\Repository\DefaultApps (You will need to give it a new name, i.e. License Monitor (New))
  2. Go to the Hub to the My Work section and open the application
  3. Click on Open to go to the Data Load Editor
  4. Go to the Run Logic section
  5. It will initially look like below. For reference, the screenshots are from the Operations Monitor but the principle applies to the License Monitor as well even though the load script will look slightly different.
    User-added image
  6. Wrap the section labelled working: with the following code:
    //begin ignoring errors parsing logs
    set errormode = 0;
    and 
    //end ignoring errors parsing logs
    set errormode = 1;?
    This will look something like this:

    User-added image
  7. Save the file
  8. Reload from the Hub or QMC
    1. From the Hub: Click on the Load Data icon in the upper right hand corner
    2. From the QMC: Apps > Select the new License or Operations Monitor App > More Actions > Reload Now
  9. Ensure that it has reloaded successfully
  10. Delete the original License or Operations Monitor app
  11. Rename the new copy, i.e. License Monitor (New) will be renamed to License Monitor
  12. Publish the new app to the Monitoring Apps stream
  13. Create a reload task to reload the new app. The default reload schedule for the default apps is to reload every hour, but you can set to this to be as frequent as your needs require.
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Last update:
‎2020-09-02 07:33 AM
Updated by: